Adding lang attribute break default font size


#1

My track to make an issue.

  1. Create html-document “exm.html”:
    Problem.

  2. Open it on:
    FF 59.0.1(32-bit), Russian Language;
    PC Windows 7, Service Pack 1, Russian Language.

  3. Change font size in FF->Properties->Font and Color->Font by default->Size to, for example, “24”.

As result, text size does not changes on the exm.html page. Text size remain 16px, not 24px.
But, if to set lang=“ru” - text size will be changed on 24px.
The same happens with any pages on the web if lang attribute not equal to “ru” - settings in FF-properties does not chages text size.


(Axel) #2

I think this has something to do with the fact that you’re setting the font size for cyrillic script.

Could you look into the advanced subdialog and check if you are in fact changing the setting for cyrillic? And that if you change the font size for latin, non-russian pages adjust their size?


#3

Exactly! Tanks, Axel.
The font size is set for each language separately. Not obvious.
The problem is solved. However, FF should hope that other users will understand this.