[BUG] device orientation API is not working


(Aras Balali Moghaddam) #1

I opened this bug when I noticed that many apps that use orientation sensor do seem to work on flatfish. I am not sure if this is something that changed in gaia, or if it is specific to flatfish. Can anyone provide some insights about what the issue is?


(Bob Thulfram) #2

I noticed this also. Not only with my Flatfish, but also my ZTE Open C. Device Orientation works fine with my original ZTE Open and Geeksphone Peak.

I tested this with my own Device Orientation app as outlined in my blog at http://firefoxosgaming.blogspot.com/2013/12/device-orientation-game-programming.html. I also have been testing this with an app in the Marketplace called Orbland.

Is this a hardware issue or an OS issue?

My original ZTE Open and Geeksphone Peak are at OS version 1.2 but my ZTE Open C is at version 1.3 and my Flatfish is at version 1.4. Did Device orientation drop out after 1.2 or are hardware manufacturers just forgetting to put it in?

I think device orientation is very important!


(Andrew [:feer56] ) #3

I grabbed a Geeksphone 1.3 build last week for my Keon and it happens that device orientation isn’t working there… This doesn’t seem high priority to be fixed though…


(Bob Thulfram) #4

Whew, thanks. I had a feeling it might be the switch from 1.2 onwards. I agree that it doesn’t seem to be a big priority, but at least I can be pretty sure that the hardware manufacturers didn’t leave out the gyroscope! It seems like every smartphone has one!

I guess I’ll put my tilt game on hold for a while. :smiley: