Build for flatfish on ubuntu 14.10


(Gabriele Vidali) #1

I just upgraded to 14.10 and I’m now facing the MAKE package complaining that it wants to be version 3.81 or 3.82 instead of version 4.
Do I have to add 14.04 repo or what ?

EDIT:
this package definetely solved the make issue (https://launchpad.net/ubuntu/utopic/amd64/make/3.81-8.2ubuntu3)


(Steve Lee) #2

Also see https://developer.mozilla.org/en-US/Firefox_OS/Firefox_OS_build_prerequisites
They’re still recommending 12.04, which while LTS, is getting old.


(Gabriele Vidali) #3

I filed a bug regarding problems with 14.10 (https://bugzilla.mozilla.org/show_bug.cgi?id=1087291) and
I’m now trying retroceding to trusty, three more packages: libvpx1_1.3.0-2_i386.deb libvpx1_1.3.0-2_amd64.deb and gcc_4.8.2-1ubuntu6_amd64.deb.

Notice:
It might be something else since recent builds are all failing https://etherpad.mozilla.org/CmJbD8V0QX


(Gabriele Vidali) #4

By retroceding all these packages:
https://launchpad.net/ubuntu/trusty/amd64/gcc/4:4.8.2-1ubuntu6
https://launchpad.net/ubuntu/saucy/i386/libvpx1/1.2.0-2
https://launchpad.net/ubuntu/saucy/amd64/libvpx1/1.2.0-2
https://launchpad.net/ubuntu/utopic/amd64/make/3.81-8.2ubuntu3

and reverting this git commit:
cd gecko
git revert
1d50c84dd8fec00f09f6acba1a3ae6bfa6edee4c…a4de3137144f6d53ef451f81201b1c65e140c3d0

it looks like it builds again
(You might need to retrocede the make package only)