Calendar events missing for March (and December)


#1

I’m on the latest OTA build offered to Foxfooders this week, though I’ve had this problem on my flame as well.

For a whole month practically, my events are missing. This happened in December, removing and readding the events brings them back temporarily. It’s happened again for March, if I go back to December those events are missing as well.

Is this happening to anyone else? Known bug? Is there a better workaround than removing and adding the calendars? The events disappear again, not sure if it’s on the next sync or restart or what, but I could do more testing.


(Valentin) #2

Hi!

I couldn’t find a known bug for this, but check the Gaia::calendar component on bugzilla maybe.

What type of calendar are you using ?


(Nhirata) #3

Does the device keep proper time between reboots? Émeric (a contributor)
found that there’s an issues with the time keeping on some devices, after
reboots and that it’s related to the QC ril.

How it relates: If you’re connected to wifi / sim , the time should auto
correct again later. My suspicion is after a reboot, it appears that
your event is gone, and then when the time gets fixed by a sync to a time
server via sim or wifi, it then will reappear.

I’m not sure what can be done about this, as I think we need QC’s help to
fix that issue…

Regards,
Naoki


#4

@Valentin Using google calendars. I thought perhaps the issue was my very old personal calendar, so I tried only adding back my work account (Google Apps). It’s having he same problem on its own.

@nhirata I don’t think time can be the problem. It is only some events that are gone, and they are gone even when the time is correct. Also, I was playing around and the events did indeed disappear while I was using the app, so possibly during a calendar sync.

To thicken the plot, I am still getting the notifications for the events, they’re just not visible. It has of course literally just occurred to me that (at least this time around) I haven’t tested to see if the events are only missing from the month view. I can’t recall if I tried different views when I had this problem in December.

I’ve just tried switching views and the events are back, but I also think it’s possible the events were showing before I tried switching views, I tried it a bit hastily. I’ll try again after they disappear again and report back when I’m confident of the behaviour.


#5

Interesting. The week view is messed up when this happens as well:

Switching back and forth between views didn’t solve the problem.

Just restarted the app, and the week view is showing up correctly now, but still no events.


(Nhirata) #6

Did this start occurring after an update happened?


#7

It could be a regression in the latest OTA. But the issue with December was just with December. January worked fine without an update to fix it.

Mozilla Discourse wrote:


nhirata

March 9

Did this start occurring after an update happened?

Visit Topic or reply to this email to respond


Previous Replies

Kensie

March 9

Interesting. The week view is messed up when this happens as well:

Switching back and forth between views didn't solve the problem.

Just restarted the app, and the week view is showing up correctly now, but still no events.

Kensie

March 9

@Valentin Using google calendars. I thought perhaps the issue was my very old personal calendar, so I tried only adding back my work account (Google Apps). It's having he same problem on its own.

@nhirata I don't think time can be the problem. It is only some events that are gone, and they are gone even when the time is correct. Also, I was playing around and the events did indeed disappear while I was using the app, so possibly during a calendar sync.

To thicken the plot, I am still getting the notifications for the events, they're just not visible. It has of course literally just occurred to me that (at least this time around) I haven't tested to see if the events are only missing from the month view. I can't recall if I tried different views when I had this problem in December.

I've just tried switching views and the events are back, but I also think it's possible the events were showing before I tried switching views, I tried it a bit hastily. I'll try again after they disappear again and report back when I'm confident of the behaviour.


Visit Topic or reply to this email to respond

To stop receiving notifications for this particular topic, click here. To unsubscribe from these emails, change your user preferences

Sent Using Firefox OS

(Nhirata) #8

Thanks for the information. I was wondering if it was because of the
process of updating that may have triggered the issue for dec. and feb.
I’m not sure if that’s the case, though and what we can do to fix it. I
guess we can wait to see what happens in March.


(Madtibo) #9

I suffer from the same bug.
No event in October :frowning:

I am on OpenC with version 2.5 commit f30c0851(from foxfood).

The events would sometime come back for a short time, very strange : I went back to october 2016 and back to today and the events appeared.
I switched app and went back to it, the events where not visible anymore.

If I remove the calendar (they are caldav calendars), the events would come back.

I have an error in WebIDE but I think it is not related to my problem :

L10nError: "present-description" not found in en-US in app://calendar.gaiamobile.org/index.html

Is there a way to force a reset of the calendar data?

have a nice