Cannot upload addon: 403 response

Hey there,

I just tried to submit a new version for one of my addons but when uploading the file (a zip in my case) the upload stops just before finishing and I get an error saying “Received an empty response from the server; status: 403”.

Logging out and back in again doesn’t fix the problem. I’ve also tried submitting a different file to the addon validator but I always get that 403 response.

Any ideas as to what’s going on?

Is it a very large file? If you’re still having problems, I suggest you file an issue with the details.

Hey Jorge,

thank you for your answer! No it’s not a very large file but after tinkering with AMO for a bit again I noticed a peculiar error message when trying to submit a new addon. I looked at the response from the addon validator error and lo and behold, it was that same error page.

It seems that some anti-tracking setting I have blocks Referers on AMO and that triggers a security error in the validator. So it’s a problem on my side.

Yep, after inspecting my settings I’ve found that I’ve set the network.http.sendRefererHeader setting in about:config so that it doesn’t send Referers on any site. I’ve fixed that now.

That error isn’t very intuitive though. Should I still submit an issue asking for improvement?

Yes, I think it’s worth investigating if we can do something about that. You can file the issue here: