Check spelling dialog starts with blank language in TB 70.0b1

With the latest 70.0b1, there appears to be a regression in the way how Check Spelling dialog is handled.

Language set to blank: When the Check Spelling dialog opens the selected Language is blank, I have to select the desired language and “Recheck Text”. Once the dialog is closed and re-opened the Language is again set to blank.

Button titles don’t match the context in Check Spelling dialog: in 70.0b1, the bottom dialog buttons (“Stop” & “Close”, bottom right, next to the “Language” selector) are always the same no matter what’s the context. Up to 60.0b4 these buttons changed to match the context. I’ll describe the (correct IMHO) behavior from 60.0b4 in contrast to 70.0b1:

  • in 60.0b4 when Check Spelling is called from the menu option “Options/Check Spelling…”, there is only “Close” button shown; 70.0b1 shows both “Stop” & “Close” both doing essentially the same thing i.e. closing the dialog, there should be only “Close” button here

  • in 60.0b4 when Check Spelling is called automatically before sending the message (with the “check spelling before send” option enabled), the buttons offered are “Stop” & “Send” perfectly matching the context; 70.0b1 shows again both “Stop” & “Close”, where “Stop” closes the dialog without sending the message, “Close” sends the message which is now confusing as it should say “Send”, as in the previous versions.

I am using two dictionaries: “English (United States)” and “English (United Kingdom)”, with the US one being my default one.

None of the issues were present in 69.0b4.