Fairphone 2 build


(Lissyx) #41

Yeah, so this is well known current breakge of m-c


#42

ok, so as i found here: https://bugzilla.mozilla.org/show_bug.cgi?id=1245091
metabug has pendant open bugs. Do i understand right that i have to be patient because its not solved yet?


(Juan Gómez) #43

Hi Novski,
Sorry for the late response… don’t have much to say about it, though.
I couldn’t test the B2G transitions branches on my FP2 , and I don’t think I could in the short-term… anyway it would be cool if start to familiarize with some of the tools we have to debug/track down problems. These are the most important:
1.- Debug builds
2.- adb logcat :slight_smile:
3.- dmesg ($adb shell dmesg 2&>1 | tee dmesg.log)

Thanks for keep on trying!! :wink:


#44

Thanks atila, im learning every day a new word. one by one… :grin:
soner or later im gona tame that FP2, no worries!


#45

Hi, community.
Im back with problems in porting to FP2. I wasn’t able to build after B2G merged a few weeks ago. Then @asppsa helped me to figure out what file caused the problem and juan helped me then in a IRC Chat to figure out was going wrong. It was that the frameworks/native repo was pulled from github.com/mozilla-b2g “b2g” repo insted of the codeaurora.org “caf”.
So he told me how to set up a correct line in the fairphone.xml file to remove that particular repository and fetch the correct one from “caf”.
But as @lissyx, added a line that includes the frameworks/native repo in this commit: https://github.com/mozilla-b2g/b2g-manifest/commit/23eb7ee9631a37f7290a6d887c1429e42641753b
what solved a problem braking the build by giving out a errormessage about MediaEngineWebRTC.o so now im back at the same place and don’t know how to solve that issue. Can somebody help out here?

log: http://pastebin.com/RMX3tR5j
fairphone.xml: https://www.irccloud.com/pastebin/rOnk9d3C/fairphone2.xml

Best Regards, Novski


(Lissyx) #46

You still lack the frameworks/native fix ?


#47

nope. I have it, but have to
<remove-project name="platform_frameworks_native"/> <project name="platform/frameworks/native" path="frameworks/native" remote="caf"/>
due to a problem with a missing fille in the b2g repo.
your line in base-l-aosp.xml looks like this:
<project name="platform_frameworks_av" path="frameworks/av" remote="b2g" revision="b2g-5.1.1_r29"/>
That doesn’t work with FP2. Juan says i need the “caf”


(Lissyx) #48

Please be more precise. “due to a missing file” which file ? It looks like the CAF remote does not have the fix either, given how it fails. Just fork it and add the fix ?


#49

no it was a different error bevor. look:
http://pastebin.com/GyfdnEqP

this was what juan told me to search for:
root@novski-B2G-fresh:~/B2G/frameworks/native/opengl/libs/EGL# grep eglGpuPerfHintQCOM * root@novski-B2G-fresh:~/B2G/frameworks/native/opengl/libs/EGL#
The file wasn’t there. So he gave me the advice to remove the b2g and go with caf.


(Lissyx) #50

Earlier you told us that you are back with the error on WebRTC build. That is symptomatic of missing fix on frameworks/native regarding the libatomic stuff.


(Lissyx) #51

commit 77c23f8067bca84476f96d663efaae636817edd5
Merge: 521c01a e92af36
Author: Thomas Zimmermann tdz@users.sourceforge.net
Date: Fri Jun 17 11:13:09 2016 +0200

Merge pull request #1 from tdz/bug-1276927

Include <atomic> for C++11 builds

commit e92af361af5155574c3f05b9544aef194b760aa0
Author: Thomas Zimmermann tdz@users.sourceforge.net
Date: Tue May 31 10:54:37 2016 +0200

Include <atomic> for C++11 builds

The C header file <stdatomic.h> is not compatible with C++. For C++11
builds, we include <atomic> instead. Compiler implementors guarantee
compatibility of memory models and data structures.

#52

yes exactly, now WebRTC error now accures because i remove b2g version of frameworks/native and fetch the caf frameworks/native version. But i need that caf version becaus in the b2g version is a missing file (eglGpuPerfHintQCOM).

So now i have to solve the problem that is solved in the b2g version also within caf.

I don’t know how…


(Lissyx) #53

Again, cherry-pick the fix on a CAF fork ?


(Lissyx) #54

git checkout -b caf_atomic_cpp caf/LA.BF.1.1.1_rb1.18
git cherry-pick e92af361af5155574c3f05b9544aef194b760aa0

If git cherry-pick fails, just abort it and try (on the same caf_atomic_cpp branch):

curl -L https://github.com/mozilla-b2g/platform_frameworks_native/pull/1.patch | git am


#55

Both don’t work.
1.
cherry pick:
fatal: bad object e92af361af5155574c3f05b9544aef194b760aa0
2.
curl -L https://github.com/mozilla-b2g/platform_frameworks_native/pull/1.patch | git am
German: error: include/binder/Binder.h ist nicht im Index
Translated: error: include/binder/Binder.h is not in Index

then i did ./repo sync
and again:
curl -L https://github.com/mozilla-b2g/platform_frameworks_native/pull/1.patch | git am
now i get:
(23) Failed writing body


#56

I did both by hand. trying a build over night.


(Lissyx) #57

Not in index? Are you doing all those inside the frameworks/native path ?


#58

no i wasn’t :grin:.

I did and it worked to apply,

so i run a build again and came a bit further it now runs for about 4h in -j1 with a 2.7Ghz core.
But still i have a build fail, now with this error:
http://pastebin.com/N1em9Ypz
German: Make: Schreibfehler
English: Make: Writhing failure

But my Harddrive is half empty:

what cold it be…?


(Lissyx) #59

Is “Schreibfehler” the whole error message ?


#60

yes. I can’t pastebin the hole log because of the size wich is over the max. that pastebin allows…
here the full bottom:
http://pastebin.com/LbMAJGaL