Fairphone 2 build


(Lissyx) #61

df -h; df -i;


#62

http://pastebin.com/892Te9aQ

should be big enough i think…


(Lissyx) #63

How much memory do you have ? Are you building on 64 bits system ?


#64

yes, i allocated 3 CPUs and 6096MB to that VM. In Total the Machine has 8CPUs and 16GB RAM.
Im always building with option -j1 on one core only…

edit: yes 64 bit system Ubuntu 14.4


(Lissyx) #65

Would be very helpful to have the real english error message, translation seems to be inaccurate. Please build with LC_ALL=C


#66

ok i changed the language of my system and build -j3 because i have to leave in less than 4h :slight_smile:
here is the log: http://pastebin.com/Z4CWN1PF
edit: now its completely a different error…
???


(Lissyx) #67

Well, what did you do exactly ? Looks like pip/virtualenv is complaining about your locale :confused:


(Lissyx) #68

Just to be sure, remove all out/ objdir-gecko/ and within your gecko tree, please |git clean -fdx|

Then:

LC_ALL=C ./build.sh -j3


#69

aha. so that may explane why a different error than befor. I Changed the system Language that may have introduced this error now…
im building as you described it currently…


#70

ok i did like that:
novski@novski-B2G:~/B2G/gecko$ git clean -fdx Removing configure Removing js/src/configure Removing js/src/old-configure Removing old-configure Removing python/psutil/build/ Removing python/virtualenv/virtualenv.pyc

then:
novski@novski-B2G:~/B2G/gecko$ sudo rm -rf out && rm -rf objdir-gecko && rm -rf gaia/profile* && ccache -C [sudo] password for novski: Cleared cache

then:
cd .. out of gecko
novski@novski-B2G:~/B2G$ LC_ALL=C ./build.sh -j3 showcommands 2>&1 | tee 160809_4-build.log

the result is different again…
log: http://pastebin.com/9m8CazT8


(Lissyx) #71

that’s not different, “write error”


#72

true… but why…


(Lissyx) #73

I don’t know.


(Fabrice) #74

Is that your host or the VM? I suspect the VM to run out of disk space even if you have plenty available on your host.


#75

Yes its the VM. But the VM shows 50GB+ free diskspace…
It is in a Paralells that lets me make dynamical disks. But that was never a problem until now.
I suspect that its more related to a checkbox i have checked in the installation process.
this one: picture
It says it allows partition resizing and snapshot taking with a logical volume management.
I will install a new VM wihout and set up the hole thin again…


#76

You should paste the output of the df -h command first, maybe you have more than enough space to build B2G OS, and it would be a shame to waste time and bandwidth reinstalling the whole VM if that’s not necessary.
My network connection is DSL, and performing the initial ./repo sync takes hours, so I tend to avoid restarting from scratch :slight_smile:


#77

its already in the topic a bit further up…
I see enough space and don’t know why it breaks if space is convenient…


#78

Oops sorry I was focused on the last error message and didn’t pay attention :confused:

I don’t have any serious lead about this issue at the moment, but could you please check these points so we can rule them out?

  1. What is the version of make you’re using? (make -v)
  2. Maybe you ran out of inodes on your filesystem because it is filled with a lot of small files (my B2G directory contains about 2,000,000 files). That’s unlikely, but just to be sure, you can check with : LANG=C sudo tune2fs -l /dev/dm-0 and report the value of the “Free inodes” field (assuming you’re using a ext2/3/4 filesystem).

#79

Nevermind, i woldn’t read 80 posts as well… :innocent:

GNU Make 3.81

Free inodes: 6428205

Thanks for your help!


(Lissyx) #80

Well, as much as I remember, “write error” in make might mean a lot of things. Try this: reproduce with -j3, and then do it with -j1. It will be easier to read the -j1 log.