Firefox iOS: disable listing recent bookmarks in top level of Bookmarks

I have Firefox for Mac, PC and iOS synced on Firefox accounts. On the Mac and PC, I don’t even have the Library button on my toolbar so I never have my recent bookmarks exposed. On Firefox iOS, the only way I know to access my bookmarks is tapping the “hamburger” in the lower right, then tapping “Your Library”, which brings up the Bookmarks menu. I can’t access Bookmarks without exposing my recent bookmarks, which are individually displayed on the top level of Bookmarks. This does not happen in the Bookmarks menu in either the PC or Mac versions of Firefox.

This is an unacceptable lapse of user security in a situation where people are very likely to be looking over your shoulder. Firefox lets us turn off search suggestions for a reason; that same reason applies here.

If there was a Recent Bookmarks folder in Bookmarks, that would be fine. Even better would be an option to not keep a list of recent bookmarks.


I have resorted to the ugly kludge of making a bookmark folder titled “throwaway” and bookmarking twenty innocuous web pages whenever I want to clear the “recently bookmarked” list.

This is 100% compatible with any version of Firefox and is 100% effective, but it feels like unnecessary makework on a browser that is actively billing itself as prioritizing user privacy.

Wholeheartedly agree with this post: This is an urgent privacy issue. Please, fix.


Yes indeed, strange this topic needs to be revived rather than the blatant privacy breach put 6ft under.

Why is it that this extremely good and security conscious browser, has this serious GAP?

Revive this topic?

The last reply to this topic was over 1 year ago . Your reply will bump the topic to the top of its list and notify anyone previously involved in the conversation.

Are you sure you want to continue this old conversation?

If syncing with the desktop which doesn’t have show recent bookmarks enabled, then the mobile interface should do the same.

As far as I know, Recent Bookmarks cannot be disabled in Firefox 78esr or Firefox 93. The old browser.bookmarks.showRecentlyBookmarked preference from the Australis days is no longer recognized by Firefox.

This worked in Linux very similar for Windows and Mac check out the 2nd link for more details.

FireFox and TOR getting rid of recent bookmarks list

-Type about:config into browser window.

-Fine I don’t care if the world blows up let me see the forbidden text.

-Copy Paste toolkit.legacyUserProfileCustomizations.stylesheets into search window.

-Set to true

-Menu (Hamburger) – Help – More Troubleshooting Information

-Profile Directory - Open Directory

-Right click - Create a new folder and name it chrome

-Open chrome

-Right click – Create new Document – Empty Document rename it userChrome.css

-Right click – Open with text editor

-Copy and Past

/* hide Recently Bookmarked */
{ display:none!important;

-Save (other modifications can be made the same way)

-Close browser and relaunch

-Sing joyful song as the hateful Recent Bookmarks List has been vanquished.

Code plagiarized from

Process plagiarized from