Flashing on OS X


(Josh Smith) #1

I am trying to flash my tablet with 2.0 (thanks Caspy7). ./adb.mac reboot boot-fastboot works, but when the device restarts (and freezes at the logo like it should), fastboot is not accessible.

I am on OS X 10.9.1.


(Mandeep) #2

Are 2.0 builds publicly available?


(Josh Smith) #3

Not publicly, but there are ways to get them. Cough…irc…cough…Caspy7…cough.


(Steve Lee) #4

@Caspy7 - you have a bad cough there.


(Steve Lee) #5

did you try lsusb to see what the id is?


(Josh Smith) #6

I did.

While fully booted:
FLATFISH:
  Product ID:    0x0003
  Vendor ID:    0x18d1  (Google Inc.)
  Version:     2.33
  Serial Number:    FLATFISH_123456
  Speed:    Up to 480 Mb/sec
  Manufacturer:    SWD
  Location ID:    0xfa130000 / 5
  Current Available (mA):    500
  Current Required (mA):    500

While in boot-fastboot:
Vendor-Specific Device:
  Product ID:    0x0fff
  Vendor ID:    0x0bb4  (HTC Corporation)
  Version:     2.00
  Serial Number:    
  Speed:    Up to 480 Mb/sec
  Manufacturer:    
  Location ID:    0xfa130000 / 5
  Current Available (mA):    500
  Current Required (mA):    Unknown (Device has not been configured)


(Steve Lee) #7

HTC!? so it definitely changes like the ZTE One.

So it’s a matter of finding out why this fails on OS X as others have flashed from Linux. Perhaps some clues from others experience with the ZTE?


(Florian Bender) #8

So according to https://wiki.mozilla.org/User:Caspy7/Flashing_the_Flatfish_bootloader, there’s still no fully working solution for flashing/updating via OS X. Is there a bug I can follow for updates?


(Josh Smith) #9

Bug 1040236 is tracking this issue!


(Florian Bender) #10

Thanks a lot!