Gateway connection impossible ?!?!

Hi all,
In order to test Webthings, I just downloaded the 0.9.2 version and loaded it on a RPi 1 B+.
I see the gateway address on my router which unfortunately is this address is already used by my current domotic gateway and don’t intend to change it. Moreover even if I temporarily deconnect my domotic it is impossible for me to access the gateway via Putty “connection refused” !!!

Two things which seems stupid to me:

  • Why SSH connections are blocked ?
  • Why don’t you use a DHCP connection ?

In the current situation I can’t test Webthings and it’s a pity. I need a DHCP connection and I also need a SSH connection to my Raspberry Pi.

The gateway does use DHCP, so something is weird on your network. A static IP address can be used, but that’s not the default. Are you sure you’re looking at the proper IP address?

Also, SSH is disabled by default, but can be enabled through the UI. If you’d like to enable it manually, plug the SD card into your computer and create and empty file named ssh on the SD card. More instructions are located here.

Hi Michael,

Thanks again for your quick reply. Regarding SSH I already knew this issue of Raspbian stretch but I had forgot it (little head, the age probably) :wink:
As for the DHCP, I think knowing the reason of this issue. The RPi 1B I use was used before for my home automation with the address. I replaced it some times ago by a RPi 2B at the same address. I think my router kept in memory his MAC and so, it gave it back his address. Clearly it’s a small bug of my internet router.

I now have to find how to change internet address of my RPi, because Idon’t remember :wink:

Result: nothing stupid, I apologize