How to build pine and m-c (Please read)


(M Ducorps) #81

Am i supposed to have in /system/b2g/apps/, if yes what process is doing this ?

or is still an environment variable issue ?

thanks for the clarification

Matth


(Lissyx) #82

gaia/Android.mk is in charge of this.


(M Ducorps) #83

Here are le logs of my last success build (-j2):
http://termbin.com/vrku

I don’t see where this path is written

Here is the git log of /gaia/Android.mk

I have tried to change those variable it seems to correspond to my issue:

In user (production) builds we put gaia apps in /system/b2g/webapps
ifneq ($(filter user userdebug, $(TARGET_BUILD_VARIANT)),)
GAIA_MAKE_FLAGS += PRODUCTION=0
B2G_SYSTEM_APPS := 0
endif

I also tried to change the Gaia_path of Android.mk

But none of this works…

It seems also that even B2G has to be in the /system/ folder but it’s not in my case…

I’m i experiencing this bug or something around it?

https://bugzilla.mozilla.org/show_bug.cgi?id=832165


#84

Do you mean to change that in: .repo/manifests/base.xml?

I tryed it like this: <project name="gaia" path="gaia" remote="b2g" revision="kanikani" />
and then: ./repo sync gaia and it fetches about 40 lines of code.
But that does not help.

I don’t understand this part. may you clarify for me?
if i use remote=“mozillaorg”, am i on the server described in the same base.xml file on the line15:
<remote name="mozillaorg" fetch="https://git.mozilla.org/releases" />

and with remote=“b2g”, on line10:
<remote name="b2g" fetch="git://github.com/mozilla-b2g/" />

??


(M Ducorps) #85

@Novski,

I’m not sure what Lissyx would mean but it shoud work with the file i sent you here:

http://termbin.com/roel

hope that help

Matth


#86

Thank you, i have seen that and also tried it but it failed as well.
Maybe ist related to my system, im building on Ubuntu 14.4, you?


(Lissyx) #87

I don’t know what you are doing. Your log is very explicit:

Gaia install path: out/target/product/generic/data/local/webapps

That’s not what we expect.

Also, the part of Android.mk confirms you don’t have a correct kanikani checkout: https://github.com/mozilla-b2g/gaia/blob/kanikani/Android.mk#L24 you should see this.

Please clean everything (out/ objdir-gecko/ gaia/profile*), make sure your base.xml references kanikani branch of gaia from b2g remote, and that you properly export GECKO_PATH to an uptodate pine tree.


(Lissyx) #88

No that is not correct, you still reference mozillaorg remote instead of b2g remote.


(Lissyx) #89

Can you be more explicit? “that does not help” is not very useful.


(Lissyx) #90

Bug 832165 was closed several times as WONTFIX. Basically you should not expect changing GAIA_PATH to work. Please stick to use gaia from B2G/gaia/ and tweak .repo/manifests/base.xml to checkout proper version.


#91

Build fails…


#92

how can i delete the mozillaorg data and get the new b2g data of gaia to my system?
Can you describe that detailed?


(Lissyx) #93

Without any log, I cannot diagnose anything.


(Lissyx) #94

This is what I have been repeating: change remote to b2g and branch kanikani instead of mozillaorg/master for gaia in base.xml, then |./repo sync gaia|.


#95

ok im building new once again. now with log. like this:
./build.sh -j1 showcommands 2>&1 | tee build.log
hope that will help you/me more…


(Lissyx) #96

Did you changed the remotes as I said ? Cleaned up everything as I said ? -j1 will be slow.


#97

yes, i changed the remote as below and after that executed: ./repo sync gaia
this is the base.xml:

<?xml version="1.0" ?>
<manifest>

  <!--
    Remotes
    -->

  <remote name="aosp" fetch="https://android.googlesource.com/" />
  <remote name="apitrace" fetch="git://github.com/apitrace/" />
  <remote name="b2g" fetch="git://github.com/mozilla-b2g/" />
  <remote name="b2gmozilla" fetch="https://git.mozilla.org/b2g" />
  <remote name="caf" fetch="git://codeaurora.org/" />
  <remote name="linaro" fetch="http://android.git.linaro.org/git-ro/" />
  <remote name="mozilla" fetch="git://github.com/mozilla/" />
  <remote name="mozillaorg" fetch="https://git.mozilla.org/releases" />

  <!--
    B2G repositories for all targets
    -->

  <project name="gaia" path="gaia" remote="b2g" revision="kanikani" />
  <project name="gecko" path="gecko" remote="mozillaorg" revision="master" />
  <project name="gonk-misc" path="gonk-misc" remote="b2g" revision="master" />
  <project name="moztt" path="external/moztt" remote="b2g" revision="master"/>
  <project name="platform_hardware_libhardware_moz" path="hardware/libhardware_moz" remote="b2g" revision="master"/>
  <project name="platform_system_libfdio" path="system/libfdio" remote="b2g" revision="master"/>
  <project name="platform_system_libpdu" path="system/libpdu" remote="b2g" revision="master"/>
  <project name="platform_system_sensorsd" path="system/sensorsd" remote="b2g" revision="master"/>

</manifest>

#98

Here it is…


(Lissyx) #99

/bin/bash: node: command not found


(Lissyx) #100

That’s when building Gaia. Then I see errors on Gecko builds that we also have on Nexus 5 L: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1c6b831237f8&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=23263691

/home/worker/workspace/gecko/android-ndk/toolchains/arm-linux-androideabi-4.9/prebuilt/linux-x86_64/lib/gcc/arm-linux-androideabi/4.9/include/stdatomic.h:40:9: error: ‘_Atomic’ does not name a type