How to hide my email address

Hello,

My email address is publicly visible, even though it says “Never shown to the public” in my account settings.

How do fix this, I don’t want to display it for anyone (registered or not registered)?