If you have a Flatfish tablet or will be receiving one, it is important that you read this post to help prevent bricking your tablet


(Caspy7) #1

See the bottom of this post for an update.

We have at least two individuals who, while testing their Flatfish devices, enabled screen reading.  Unfortunately the screen reader mode in the build of Firefox OS that came on the devices is quite broken and it may not be possible to disable the mode (among other issues it causes).  
Because USB debugging was not enabled on the devices and we have not found a way to enter a usable recovery mode, it is uncertain how these devices will be made fully usable again.

Here are the takeaways:

  • Do not test the screen reader in the FxOS build that came on the tablet.
  • As soon as you are able, enable USB Debugging
  • Launch the Settings app from its gear icon on the home screen.
    • Go to Device Information > More Information and check the Developer Menu checkbox.
  • Tap the new Developer menu on the left and set Debugging via USB to “ADB and DevTools”.

This way if things get very broken for you, you can always flash a working OS to the device.

UPDATE:
We now know that the default setting on new tablets in fact has USB debugging enabled ( ADB only).  And new builds now default to ADB and DevTools, which is a step up.

If you are on the original build, you should not turn on the screen reader, however it is more important that you upgrade to a newer version of the OS as we are no longer testing 1.4 and there is no value to running it.

You can find instructions to upgrade to the newest OS here.
(Also, we are now able to recover “bricked” devices.)


(Logan Rosen) #2

(Kairo) #3

Is the tablet unable to get into fastboot mode? If you can get in there, you should be able to delete/reset the user data and that should also make it forget about screen reader mode.


(Steve Lee) #4

What would really help us get to the bottom of this is if someone with a device could:

a) Talk to the accessibility group on #accessibility. MarcoZ or eeejay would be best but any should help.
b) let us have the build identifier and git commit ref etc and we’ll talk to accessibility.

Don’t forget to be very careful about turning the screen reader on, as mentioned above.

Moving forward the community is looking into how to provide easy to apply updates.


(Steve Lee) #5

kairo: At this point it appears not as debugging is off by default. Also no device recovery mode has been found yet.


#6

I emailed @asa about adding this information to the email sent to participants when a tablet is shipped until the condition is fixed.

rcs


(Steve Lee) #7

Great idea!


#8

I added an alert to the main TCP wiki page

rcs


(Kairo) #9

slee: usually, fastboot mode can be entered (if it’s available) by pressing down some volume button while booting or something similar. I was thinking of that, not about adb being available (which always depends on the user turning on debug mode and unlocking the device).


(Steve Lee) #10

Ah, that’s good to know. Is not the case on my ZTE One AFAIK as volume up and power on enters a firefox OS recovery menu, but I guess may give fastboot access too. I wondered why there were 2 essentially equivalent remote debug modes adb and fastboot.


(Caspy7) #11

To clarity, we have tried entering fastboot/recovery via the volume buttons while booting as well as other combinations, but with no luck.


(Caspy7) #12

This is something we want everyone who already has a device to do ASAP as well.
Should we contact them?


(Kairo) #13

Thanks. I think we should get some clarity as to why there is no button combination to get there (or if it’s hidden elsewhere).


(Steve Lee) #14

In case anyone wants to try using the screen reader and turn the setting back off there are instructions on this blog post. A least one person has tried these with no success at all.


(Caspy7) #15

I have been attempting to get in touch with someone who knows something at InFocus.
While the device is plugged, and trying different combinations, I will hear a low tone (USB disconnected) on my PC. My suspicion is that it’s supposed to be the correct combination, but failed somehow - aka, it’s broke. I’ll be happy to be wrong.
I don’t know how to get at the battery without risking breaking it. Perhaps the back comes off, but I’d like some assurance that it’s not screwing up the device before I do so.

The first girl I spoke with on the support line suggested that discharging it completely might somehow do the trick.


(Caspy7) #16

To clarify again, the steps outlined in that post do not work in the build that comes with the tablets.
I’ve spoken with one of the testers who is stuck in screen reader mode and swiping with two fingers between homescreen screens does not work and using the volume buttons to toggle it also does not work.


(Kairo) #17

Of course, “InFocus” is AFAIK just a brand of Foxconn. Not sure who at Foxconn might be a contact for us there, I guess you need to ask Asa.


(Steve Lee) #18

I’m not sure how battery discharge will help as settings are likely to be in non volatile memory (at least I would hope they are). Worth a try though.


(Steve Lee) #19

I pinged @asa again, this time by email


(Pavithran) #20

Looks like mine also got bricked. The sad thing is I read the instructions and was careful not to enable the screen reader. I did enable adb but I dont know how the screen reader got enabled when I plugged in the USB and tried to connect via app manager. :frowning:

Is there a way to reset the device ? As of now I havent found any reset holes !