If you have a Flatfish tablet or will be receiving one, it is important that you read this post to help prevent bricking your tablet


(Pavithran) #21

Ohh yeah like the above posts

Adb devices lists flatfish succesfully , I am able to access shell.

fastboot reboot doesnt work . :frowning:

Is there a build which can be installed ?


(Caspy7) #22

pavithran, if you have enabled USB debugging on the device, I don’t think there’s a need to consider this a permanent “bricking” yet.
It’s curious that screen reader became enabled without you setting it though.
Are you able to come on IRC (on #TCP) to talk about it?
I think I’m close to having a script to easily flash the OS.


(Steve Lee) #23

As you have debugging enabled you should be able to reset userdata to reset the settings. I’m not sure if you need to delete it or reflash a clean version. Someone on IRC #tcp mght be able to help.

It’s weird that it enable without you turning it on. That might explain why others have it on as well. Please let us know if you manage to reproduce it.


(Steve Lee) #24

oh, I now see Caspy7 already answered - sorry.


(Raniere) #25

Same situation of @pavithran =(


(Raniere) #26

@pavithran

$ adb shell
# wipe data
# reboot

Works for me.


(Steve Lee) #27

Are you saying you turned on another option and the screen reader also turned on? That would be bad.
If so, which options(s) did you turn on?


(Steve Lee) #28

thanks - what exactly is “wipe data”?


(Pavithran) #29

Yes you are right :smile:


(Pavithran) #30

Thanks a lot @raniere . Yes it also worked for me , I was able to wipe the data and reboot , it all works great now. :smiley:


(Pavithran) #31

Yes thats weird , I will try to reproduce and post a bug report.


(Steve Lee) #32

Thanks to @MarcoZehe in the #accessibility group we have got to the bottom of this problem.

  • The screen reader IS working, though the speech output is not.
  • The volume up/down toggle for screen reader on/off is not available in the shipped build, It landed later.
  • If you get to the home screen with the screen reader enabled it is impossible to scroll to the 2nd home page with the 2 finger scroll to access settings etc if there are no icons in the main area. Unfortunately the tablets ship in this condition.
  • install any app so it’s icon appears on the 1st home screen as soon as possible to avoid the problem (un proven).
  • ADB debugging was enabled by default - others have found it was off by default. With debugging on it is possible to wipe the data to reset the tablet.

Please see bug 1018144 for full details and a work-around


(Túlio Albuquerque) #33

I was able do disable reader mode by installing https://github.com/tulio-albuquerque/Firefox-OS-Boilerplate-App, there is a option to open settings app, after that I navigate to the reader option and disable it


(Túlio Albuquerque) #34

forgive me, I reset the device :smile:


(Steve Lee) #35

Thanks for the update. Going straight to the settings sounds good.

How did you reset the device? Via ADB from a PC? Or did you find a magic button combination we should know about?.


(Túlio Albuquerque) #36

In the settings app there is a reset button on Device information -> More Information, at least on 1.4


(Steve Lee) #37

doah! Of course. By the way once you had installed an app having an icon on the 1st home screen meant you should have been able to 2 finger swipe to the right to get to the 2nd home screen with settings.


(Túlio Albuquerque) #38

I tried that and it didn’t work


(Veera Manikanta) #39

my tablet got stuck.Anyone help me out of this


(Caspy7) #40

Can you be more specific?
How is it stuck? Is it stuck in reader mode?
It might be easier if you tried going into the #TCP chatroom on IRC to troubleshoot it.