[IMPORTANT] Keeping the build green


(Lissyx) #22

Good news, looks like TaskCluster cache issue is now fixed. I have retriggered jobs on central and pine :slight_smile:


(Ben Francis) #23

\o/


(Lissyx) #24

And m-c is back on GREEN!

https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-searchStr=b2g&filter-tier=1&filter-tier=2&filter-tier=3&selectedJob=4363725


(Lissyx) #25

I have updated the first post with autoland links, since we might have mozilla-central breakages coming from that one.


(M Ducorps) #26

As reported by @asppsa in Telegram

Mozilla-inbound,
B2G Device Image opt Aries Device Image b2g-device-aries-eng/opt Aries(Be)

./shinano-common/extract-files.sh: line 68: adb: command not found
/home/worker/workspace/gecko/dom/media/webrtc/MediaEngineGonkVideoSource.cpp:417:89: error: use of deleted function 'RefPtr::operator T*() const && [with T = mozilla::layers::ImageBridgeChild]'
make[6]: *** [Unified_cpp_dom_media_webrtc0.o] Error 1
make[5]: *** [dom/media/webrtc/target] Error 2
make[5]: *** Waiting for unfinished jobs…
make[4]: *** [compile] Error 2
make[3]: *** [default] Error 2
make[2]: *** [realbuild] Error 2
make[1]: *** [build] Error 2
make: *** [out/target/product/aries/obj/DATA/gecko_intermediates/gecko] Error 2
Return code: 2
failed to build
Running post_fatal callback…
Exiting 2

Bug Open :
https://bugzilla.mozilla.org/show_bug.cgi?id=1302641


(Lissyx) #27

Thanks, but remember to mark this as blocking bug 1245091


(M Ducorps) #28

effectively forget that step :blush:


(M Ducorps) #29

New bug opened for mulet here.

https://bugzilla.mozilla.org/show_bug.cgi?id=1303243

Matth


(Lissyx) #30

OK thanks for this but it looks like this was related to a more general
bustage, trees are green after a couple of backouts :slight_smile:

<
https://ci3.googleusercontent.com/proxy/BDx5AZH6N01E--Jy3-r3TZm7JMXk1EnmZ5tQaO2KlPizNdw7vAIUZbPSwRiU-0eKHKB6NBxL7714sDthsMTnR7nkSpCWqj-t7nMEAl3XhCQFTtvCYHJ8Q4_QkwvTRzoi-pIwYQvCvccf8obmHyFSroqhfoiW43n5oFgKBRR1oJWc=s0-d-e1-ft#https://discourse.mozilla-community.org/user_avatar/discourse.mozilla-community.org/m.ducorps/45/5251_1.png>
m.ducorps M Ducorps
September 16

New bug opened for mulet here.

Bug 1303243 - Mozilla inbound - Mulet build Job failing - Unsuccessful
Execution Steps


(M Ducorps) #31

ah ok good news !

For my information what does backout means ?

Thanks !

Matth.


(Lissyx) #32

backout <=> revert, the changes have been removed and the developper has to fix it :).

For reference, when you file bug, don’t forget to add the meta b2g build issue as blocking, and set the bug title to the error visible in treeherder, it makes it much much easier for others to know if something has already been reported or not.


(M Ducorps) #33

Yes, this was done in my last bug :wink:

Effectively It was not the best description and i forget the link… my bad. :blush:

Matth


(M Ducorps) #34

mozilla-inboud B2G Device Image opt Aries

…/shinano-common/extract-files.sh: line 68: adb: command not found

https://bugzilla.mozilla.org/show_bug.cgi?id=1305328

Matth