Is it possible to flash Android on a Flatfish?


(Fjoerfoks) #41

This https://mykzilla.org/2016/08/30/graphene-on-gecko-without-b2g/ might be interesting though.


(YFdyh000) #42

I want to share some of my progress.

I get this Android system to basic work, if remove/disabled by “#” the “dev_mount extsd …” line in /system/etc/vold.fstab. In addition, add dalvik.vm.* parameters to build.prop may fix Out of memory issue in some apps. A patch pack as reference: https://dl.dropboxusercontent.com/u/72126631/flash-patch.zip

Still not working:
Front and rear camera, it always get a crash, after “D/HALCameraFactory( 1272): Calling process is: …” log in adb logcat.
GPS service, due to /data/gps/.gps.interface.pipe.to_gpsd permission issue, I did not find its origin.
Light sensor not working anywhere, and the option will not be saved. I have not research it.

mass_storage is not appear, due to /system/framework/framework-res.apk/res/xml/storage_list.xml and perhaps there are other reasons.
See Issue 204926: [API 17 Emulator] Storage settings crashes on opening, Settings app crashes may is its own problem only, the system issues does not involve the issue.

“fastboot boot <boot.img>” (booting without flashing) is not work always, FASTBOOT screen will frozen. “fastboot flash boot boot.img” is work.

“Battery usage data not available” (power_usage_not_available) in Settings - Battery. power_profile.xml needs be updated.
Gallery - menu - Settings get a blank screen.
No backup options in Settings - Backup & Restore.
Phone-related apps should not be bundled. Mobile data should not appear in Battery usage and ON.

“on post-fs-data”, “#/data/gps permission” and “mkdir /data/gps 0777 system system” lines in boot.img/initrd/init.flatfish.rc, but modifying them did not solve the problem. bootimg --unpack-bootimg & bootimg --repack-bootimg to modifying.
I modified version (only streamline and try): https://dl.dropboxusercontent.com/u/72126631/boot-new.img

adb push android.hardware.location.gps.xml /etc/permissions/ may be related, but it seems no effect. I have the factory image for “Infocus NewTab CS1” as a comparison, filename: CS1USR_A442_004_009_BB05_CN.zip. Unfortunately, I still cannot find the image resources for F1. It may be called: F1PUSR_A442_003_013_16AE_CN, based on a photo on web.


(YFdyh000) #43

I’ve got the sdcard and extsd working for now, usbhost1 (OTG) is not tested. Other issues are the lack of progress.
https://mega.nz/#!FE0gHCSL!ru6P720dyeiuItV5ik4MNrAegXM9CXpMCIZIauuyLX4


(Borisbudini) #44

Have you tried flashing gapps after patching?


(YFdyh000) #45

No, I just heard about it and are not interested.


(Neo2shyalien) #46

Hello all :slight_smile:
One of the biggest problems of the build is broken mpg4 decoding - for example try to play video from youtube and watch logcat :slight_smile: I will check the patches and if everything works well I will provide new build with them :slight_smile:
Also everybody is welcome to contribute to my repo https://github.com/Neo2SHYAlien/device-flatfish/tree/aosp-4.2.2_r1 :slight_smile: I did those build before year ago :slight_smile:


(Neo2shyalien) #47

@yfdyh000 thanks for patches. Everything works well.
Please submit them to the repo after that I will make new build with them.
I stopped my work over android over flatfish before year but now I’m encouraged to start again. Thanks ppl for the work :slight_smile:

p.s: here is twrp recovery (old build) - https://drive.google.com/file/d/0B_jjzpkUjqNWcWdZLWxRLXlIMWc/view?usp=sharing


(YFdyh000) #48

I’m looking forward to it.


(Neo2shyalien) #49

I already make new img with fixed storage and appended settings of dalvik.vm.*

I want to try to append SU and some other little touches before releasing it. I’m using my tablet for around 12h without freezes any reboots and etc. I try to play game (summoners wars) everything is sooth enough for DD usage.

My future road-map is

  1. trying to fix mpeg4 decoding - B2G had the same issue in older versions
  2. trying to remove all phone related apps and services
  3. precompile the kernel and improve IO performance
  4. Make CM build

p.s What think about moving the thread to XDA ?


(Fjoerfoks) #50

As being the originator of this post, I really appreciate your hard work and am looking forward to a working image.
B.t.w., which Android are you flashing?


(Neo2shyalien) #51

Thank you I’m glad to see my work is helpful. Thank you @Borisbudini for sharing it with the people :slight_smile: I will highly appreciate any contribution to my git repo

I’m using android-4.2.2_r1. This is the base which is used from Mozilla for FFOS for flatfish :slight_smile: When I start to work over this project I don’t have any knowledge for android building at all, so the best base is original one :wink:


(Borisbudini) #52

:hushed: What’s this? @Neo2SHYAlien joined discourse? Great!! I can tell that we are way closer to having android now that Neo is here. A couple of things:
Since we are working on flatfish it would be smarter to have this as “The Thread” and link the xda ones with this one
I may help with some small things as s, busybox etc, but nothing tht would bring peace to the world. Also thanks for the repo Neo
Keep on :firefox:


(Neo2shyalien) #53

@Borisbudini actually this is surprise and for me :grin:
I make new build with busybox so just skip this point. I have to make new repo for manifests.
I found that the flatfish don’t go in deep sleep and the power consummation on screen off is high. My tablet die for a day but I drain ~1/4 with gaming… Please somebody to install cpu spy and check yours.
I highly recommend to change the io scheduler to noop, now default one is deadline. After the change Quadrant give me really better benchmark result.

p.s In the next few days I will make new thread in XDA


(Neo2shyalien) #54

Deep sleep working fine. I forgot to remove wifi always on setting :confounded: . ~5% for 8h discharge


(Neo2shyalien) #55

@yfdyh000 can you please give me details about the changes in framework-res.apk. If you are able to send PM please share the details via PM, I didn’t find option for private message :frowning:
Otherwise the new build is more or less ready.


(YFdyh000) #56

@Neo2SHYAlien About changes in framework-res.apk
I uses APKDB tool (http://www.idoog.cn/?p=2933) to handle it.
You can pack, unpack and diff them (with others tool).

I only modified two files in /xml, storage_list.xml and power_profile.xml.
power_profile.xml is copied from CS1. The main purpose is to correct battery capacity information to 7000mA (some apps use it), the other is incidental.
Some .png files changes is unexpected, I don’t remembered that I changed them.


(Neo2shyalien) #57

@yfdyh000 please send me both storage_list.xml and power_profile.xml files. I dont have windows… I already make storage_list.xml but will be better to valide my work.
What is CS1 ?


(YFdyh000) #58

@Neo2SHYAlien https://dl.dropboxusercontent.com/u/72126631/2016-09-23%20xml.zip
The image for “Infocus NewTab CS1”, I mentioned it before in this topic.


(Neo2shyalien) #59

Thank you @yfdyh000

The new build is ready.
The changes are:

  • Integrated @yfdyh000 patches. Storage and for battery information. No need to apply them manually.
  • fixed mpeg4 decoding - happy video
  • improve battery life - enabled deep sleep. dont forget to edit wifi sleep policy !!!
  • added busybox
  • changes in tcp buffer settings
  • paralytically removed phone functionality

Here is the link for the files. Also if you wan you can flash chainfire su via recovery https://download.chainfire.eu/696/supersu/

p.s In the next few days I will update git because there is a lot changes :slight_smile:
p.s 2 I found that the compass doesn’t work - already fixed… Probably and gyroscope.


(Borisbudini) #60

charging so i can test