Is it possible to flash Android on a Flatfish?


(Neo2shyalien) #81

Hmmmm google accounts work fine - otherwise I’m unable to install apps. Which google apps you download ? From my drive ? Also keyboard muting works fine. Did you clear cache ? This can be done via twrp recovery (checkout my previous posts for link) or
fastboot erase cache


(Michael Bauer) #82

After installation, the Add Account option was not responsive. I thought I saw something about that in an earlier post so I figured I could mostly work around it by installing the apk I wanted directly, starting with Firefox. I have not been able to install anything from Play.
Ran your erase command but that doesn’t seem to have done anything. I also notice that adding my Firefox sync account somehow seems to have hard-wired itself into the system. It shows under Settings and though there is an Add Account option, this simply pulls up the Firefox account. I tried disconnecting the Fx account but when I do that and go to Add Account, it opens the browsers and pulls up the Fx login page :joy:


(Neo2shyalien) #83

Dude you make something wrong, but I’m not sure what. Everything from that you report as problem works fine :slight_smile: At the moment the well know issues are camera, storage menu in settings, light sensor, gps and hardware video decoding everything else works fine.


(Neo2shyalien) #84

@yfdyh000 patch like this http://pastebin.com/ZLbkEPx4 should fix storage issue. Unfortunately I’m not able to test it in the next few days. What do you think ?


(Michael Bauer) #85

It’s been that kind of year for me, to be honest… I’m ok with what I have for now, mainly use it for browsing the web anyway and that works.
I’ll keep applying the updates to the imgs as they come along, maybe it’ll go away.


(Fjoerfoks) #86

I managed to flash my Flatfish with Android for the first time from Windows 10.
I first had to reinstall the unsigned driver, after that the install went fine.

I encounter the same trouble as not being able to add an account.
Can you tell me exactly how to flash Gapps you are referring to?
Do I need to unzip it first and what is the commandline to install?
TIA and many thanks for your great work!


(Neo2shyalien) #87

You should flash them via recovery. Place zip file in internal storage. After that via adb restart in recovery. I post link for twrp in some of my previous replays.


(Fjoerfoks) #88

What is the correct commandline to install twrp?
And how can I put the zip-files onto internal storage?


(Neo2shyalien) #89

I strongly suggest everybody to install xposed framework and gravitybox module for JB. My AOSP now have APM settings (for some reason when I patch the android framework for native apm this break build), custom quick settings. Immersive mode enabled…


(YFdyh000) #90

Two unmentioned defects:

  1. No Trim support, including “LagFix (fstrim)” report: “FSTRIM: Operation not supported on transport endpoint.”.
  2. No sunxi-temperature module, the battery temperature is always reported as 30.0℃.

(Neo2shyalien) #91

130|root@android:/ # fstrim -v /data fstrim: FITRIM: Operation not supported on transport endpoint 1|root@android:/ # fstrim -v /cache/ fstrim: FITRIM: Operation not supported on transport endpoint
There 2 options - kernel related issue or controller doesn’t support triming.

1|root@android:/ # cat /sys/devices/platform/sun6i-i2c.1/i2c-1/1-0034/axp22-supplyer.19/power_supply/battery/temp 300
Look like the module is loaded. Differently I have to rebuild the kernel instead of using the per-builded from mozilla.


(Iacopo Benesperi) #92

Hello everybody, I had a few problems logging in and then I was busy, but I wanted to take a moment to thanks everybody who worked to port Android to flatfish. Thank you very much for your work!


(alex_mayorga) #93

¡Hola!

Has anyone else successfully done this? If so, please share some “for dummies” instructions.

Right now I’m stuck as “adb devices” comes back blank even when there are rules for both 18d1 and 0bb4 and both ADB and DevTools are turned on into the device.

Firmware Revision: flatfish_20150225-2003
Build Identifier: 20150519172335

¡Gracias!


(Neo2shyalien) #94

Hello everybody. Happy new year.

Last week I was sick so I had enough time to fix some things in my repos and to make it complete.


(Kalpa Welivitigoda) #95

Hi all,

Thanks a lot for this effort. I am also using flatfish and count me in as another tester. I followed the steps provided by @safwan and was able to successfully boot android!. Now I am into following the rest of the discussion and to solve the SD card issue.


(Neo2shyalien) #96

@callkalpa Did you install my last images - they are with storage patches ?


(Kalpa Welivitigoda) #97

Hi @Neo2SHYAlien,

I managed to fix the storage issue by editing vold.fstab


(Kalpa Welivitigoda) #98

And I managed to install http://mupdf.com/, this is a fairly ok PDF reader. I have been using it for like a day now, didn’t encounter any crashes, works fine for me.


(Neo2shyalien) #99

Can you please share what changes you did and which images you use for the installation ?


(Kalpa Welivitigoda) #100

I followed the instructions at https://discourse.mozilla-community.org/t/is-it-possible-to-flash-android-on-a-flatfish/4396/32?u=callkalpa