Is it possible to flash Android on a Flatfish?


(Neo2shyalien) #101

Ok, can you please install my latest images from the link above and check again for the issues :slight_smile:


(Kalpa Welivitigoda) #102

I just installed the provided images and yes I could read PDFs in my SD without any issue. Further now I can watch youtube videos as well. How ever when I go to settings -> storage, it crashes.


(Neo2shyalien) #103

Yes this is well know issue. The old android versions related on some “hardcode” paths. I already tried to fix it with path changing int the init script and overlay but for some reason the final result was not bootable image.

At the moment I’m trying to figure out the hardware video decoding because is broken and at the moment flatfish using software which not allowing HD videos (better than nothing).


(Sandeep Sharma) #104

Hi everyone! thanks for providing all these resources to Flash Android. my tablet certainly working better now but i am facing a problem while flashing google app package via recovery. it shows package installed successfully while flashing but when i switch on the tab, there is no change inside, no google app installed. i am not able to figure out what i am doing wrong in this. can anyone suggest what i can do regarding this?


(Evertton de Lima) #105

Hi! I also experienced this problem. Extract the package and transfer the system directory via adb.


(Neo2shyalien) #106

Boyz did you use the gaps zip from my G drive ? I used it before few days because I’m testing new build, and didn’t met any issues.


(daniel camacho) #108

yes i have, i flash my thablet yesterday and with all the files that are in your google drive, thank you very much for your effort and time, is there any new things that you added? im expecting for fix for the camera or a new higher android buil, but till now everything works for me, also ive installed xposed and added a lot of features. thanks to all involved in this development


(Michal Stanke) #109

Hi. May I ask about the right procedure how to install gapps?

I have install the image from https://discourse.mozilla-community.org/t/is-it-possible-to-flash-android-on-a-flatfish/4396/59?u=mstanke and tried to install gapps also from here and than from https://discourse.mozilla-community.org/t/is-it-possible-to-flash-android-on-a-flatfish/4396/63?u=mstanke from the recovery, but after booting the tablet, everything is like before and no gapps appeared installed. Version from http://www.teamandroid.com/gapps/ worked after installing from TWRP.

Also it looks like the storage patch is not included in these images. After opening storage settings the app crash, so the only way, how to access the storage is adb, which I have used to push the gapps zip to /sdcard.

It would be nice to have some repo with all the binaries and latest instructions how to properly flash Android on Flatfish and the gapps later.


(Neo2shyalien) #110

Yeap, I have plans to make XDA thread because I have a need from some devs help but nobody from this community helps me except @yfdyh000. In the top of thread will have both of them :slight_smile:


(daniel camacho) #111

why do i only have 2 gb of internal memory for apps?


(Neo2shyalien) #112

Hardware size of data partition :slight_smile:


(Merike) #113

I’m stuck on the same problem. Sideloading gapps install appears to work successfully yet no apps are present after reboot. Could you clarify how exactly TWRP helped you? Which build or what steps?


(Michal Stanke) #114

I had to install flash TWRP image first from here:
adb reboot bootloader
fastboot flash recovery twrp-recovery.img.img
fastboot reboot

With TWRP installed and gapps zip file copied to /sdcard, I have restarted to recovery mode and installed the gapps from TWRP recovery.


(Merike) #115

Success! Thank you, I missed the TWRP part initially in this very long thread :slight_smile:


(Borisbudini) #116

You think we can change that?


(Daniele Scasciafratte) #117

It is possible to have an updated guide with all the links and instructions to avoid to read all the 115 posts?

Thank you guys!


(Daniele Scasciafratte) #118

I am the flatfish with android now but I am not sure about twrp, how I can entry on recovery mode to flash supersu?
I don’t care so much of gapps on the tablet (f-droid forever).


(Michal Stanke) #119

I have downloaded TWRP image from here. Than I have connected the tablet via USB and run these commands:
adb reboot bootloader
fastboot flash recovery twrp-recovery.img.img
fastboot reboot

To open the recovery mode you need to turn the tablet off and than press and hold volume down (I think) and the power button.


(Daniele Scasciafratte) #120

Thank you twrp is working but not detect the external sd card while with adb reboot recovery I entered in recovery without issues.


(Michal Stanke) #121

On my Flatfish the external SD card does not work at all. All I need to install from the card I had to upload with adb to the internal storage.