No extension on saved screenshots


When ever I take a screenshot and download it (instead of saving to Mozilla), I have to manually add the .png extension. Otherwise it will just be a file with no extension.

(Clouserw) #2

I haven’t heard of this issue before. Can you give us more information? What version of Firefox? Are you running other add-ons? Can you be specific about the steps to reproduce?

When I download an image, it doesn’t prompt me for a name at all, just goes right to my download directory. Are you saying you’re prompted for a name by firefox or you are renaming it later after it’s already saved?

Thanks for the info.


Add-ons I use are HTTPS Everywhere, 2 ad blockers, MEGA Sync, and Enhancer for YouTube. I use Noscript sometimes, but I never have while screenshotting. I made sure everything is updated.

The screenshot is slightly off, so let me explain further. When I go to “download” the screenshot (instead of uploading) I get prompted for a name. If I leave it as is (the default name/directory) there’s like a 50/50 chance that it will have the .png extension, but if I change the name or directory of the image then it will just be a file with no extension, and I have to manually put in the .png extension.

(Clouserw) #4

Thanks for the details. I filed this at

(Cosmin) #5

ValleyKnight thanks for reporting this!

Unfortunately I haven’t managed to reproduce this issue on latest Firefox (58.0.2) release with the described add-ons installed.
ValleyKnight, do you encounter this issue on Windows 7 with Firefox 58.0.2 release or latest Nightly (60.0a1) build? Just to be sure, do you have the “Always ask where to save files” option set in “about:preferences” or maybe any custom settings related to downloads?

Also, if you don’t mind can you please retest this issue on Safe Mode, maybe even on a new profile to eliminate custom settings as a possible cause?


I’m running the latest official version (58.0.2) on Windows 7 Ultimate (64 bit). I left all of the settings at the default Firefox has set (except for the homepage, but that shouldn’t matter).

Edit: It appears that I do have the option “Always ask where to save files” turned on.

I’ll reply again when I try it in Safe Mode.


I just tried it in Safe Mode.

It’s the same, except for one thing.

You know how I said if I keep the same name/directory, then there was a 50/50 chance of the .png extension being added?

In Safe Mode it always saves the .png extension as long as I keep the same name/directory. Whenever I change the name/directory it never saves the .png extension.