Note compatibilty?


#1

Hi,

My notes says it is no longer compatible with my version of Firefox. Where are all my synced notes now?


(vladikoff) #2

Hello, what version of Firefox are you running?

We have compatibility set for Firefox Quantum and higher, see https://github.com/mozilla/notes/blob/master/src/manifest.json#L11

Also your synced Notes should still be encrypted on the server, so if you login to Notes in Firefox Quantum you should be able to get those back. Hope this helps!


#3

I am not upgrading to Firefox Quantum because I don’t have add-on compatibility with it. Is there an older version of Notes I could use? I would really appreciate it.


(Graham Perrin) #4

https://testpilot.firefox.com/ observes:

Test Pilot requires Firefox 63 or higher

https://testpilot.firefox.com/experiments/notes observes:

Notes requires Firefox 57 or later.

With Waterfox 56.2.5 on FreeBSD-CURRENT, I:

  1. temporarily set my user agent string to a compatible version:

Mozilla/5.0 (X11; FreeBSD amd64; rv:63.0) Gecko/20100101 Firefox/63.0

– then:

  1. enabled Notes
  2. reverted to an incompatible UA string
  3. disabled Test Pilot 3.0.6vffecb95
  4. continued using Notes.

I should not treat it as compatible for bug reporting purposes etc., but most features are usable.

Issues (on Waterfox 56.2.5)

The toolbar button is present but non-effective.

The context menu option Add to Notes is effective only if the sidebar is open and switched to Notes before use of the option.