Password with special characters, escape do not work

Hi Guys,

Mybe its more rasbian then mozilla IOT question, however I’ve faced following issue:

I was trying to setup gateway by connecting it to a WIFI network with following passphrase: Xxxxx_“X.X.Xxxx-Xxxx”_XXXX.!@

A gateway couldn’t establish connection and after power off/on I could see “Webthings” network available , which means that there is WIFI connectivity issue.

After analyzing: /etc/wpa_supplicant/wpa_supplicant.conf I’ve noticed that psk passphrase has been set into something like this:
Xxxxx_“X.X.Xxxx-Xxxx”_XXXX.!@ (second quote has not been escaped)

I was trying to escape it manually, however it didin’t help.

Do you have any idea how to provide “my” password to finalize the configuration and have a gateway accessible from the internet.

Is there any set of manual steps I need to perform after this step (adding correct WIFI password into wpa_supplicant.conf) to finalize gateway cofiguration without web interface?

No, after fixing wpa_supplicant.conf, just reboot. If your Pi connects to the network, the gateway should be happy.

Hi mrstegeman

It seems that ,afer setting up wifi network correctly on a gateway,a fter reboot ‘Webthings’ network still appears and gateway is not accessible from internet.

Are you sure is should works?

I there any other way to avoid WIFI configuration screen(IOT) appears after gateway reboot?

Finally network connection works fine, steps to configure it:

  1. Select ‘Skip’ when prompted for WIFI configration on ‘gateway.local’ website
  2. upload wpa_suplicant.conf into SD card (boot directory)
  3. insert SD card into raspberry and boot again

Now I’m going to check how to fix quotes in a password issue

quotes in the password -> the best way to workaround this issue is to generate a hash with following command and paste output into wpa_supplicant.conf


Sample output:


It works for me!!