Raspberry Pi 4 Iot Stopped Working


I have been using a Raspberry Pi 4 running Iot for several months without issue.

Today I got home and my automations weren’t working. I was not able to reach my IoT page using the Mozilla-iot page or the local page. The device was plugged in. I power cycled it several times without any change. I tried WiFi and Ethernet and the device is still inaccessible. My router does detect the raspberry pi when it is powered on.

I do not have a micro hdmi cable so have never plugged the raspberry pi directly into a monitor but could get one.

Basically I don’t even know where to start. I have a windows computer. I don’t mind formatting the sd card, but would really really like to keep all my settings if possible.

Any assistance would be greatly appreciated.


My guess is that your SD card has died. Can you hook up a monitor and see if your RPi is booting?

I would have to agree. Slight possibility your device is getting too hot DOUBT it though he is right…

Ugh I hope it’s not the SD card. Have only had this thing running for a couple months. Not sure how I would have a reliable device running if the sd card corrupts so quickly. I’m stopping by microcenter to get a microhdmi cable today. Have never plugged this rasberry pi in to a monitor before.

So I got the microHDMI cable. The rasberry pi boots. Looking at the text during the boot process, everything looks ok. It finally presents me with a prompt for a username and password. Having never done this before, I tried login: rasberry and password: pi which did not work. I also tried my username and password I use to access the rasberry pi remotely which also didn’t work. During all of this, I attempted to access the remote site which also did not work. Any other suggestions?

Username is pi, password is raspberry. You had them backwards. :smiley:

Just tried that and it didn’t work either.

I plugged the SD card into my windows PC and was able to extract all the files using ext2explore so at least now I have a backup if that will end up helping.

1 Like

Since the RPi does boot, and your router does see it, find out what IP address your router is assigning to it from your router’s interface (assuming you are using DHCP as opposed to a static address). Try accessing it directly from the IP and see what happens. Since you have been switching back and forth between Ethernet and WiFi, there is a good chance one of them is still set for DHCP.

Unfortunately I tried that but it didn’t work either. Think I just need to start over unfortunately.

Check if your Keyboard for typing the password matches the english-us keys.
My swiss keyboards don‘t work eather until i press the keys as if it wold be a en-us one.

Yes I did that. The keyboard was slightly different but I figured out what the layout was and made changes.

I guess my new question is that now that I have a backup, can I just copy over certain folders to a new installation and pick up where I left off with all my devices and plugins and automations?

/home/pi/.mozilla-iot contains all of the persistent data from the gateway, so if you just copy that back over, everything should run as usual.