Roms - Alcatel One Touch Fire


(Cyril SAINTIGNY) #21

Hi @penserbjorne,

does this rom apply to One Touch Fire E (ONE TOUCH 6015X)?

regards


(Helmar Gerloni) #22

@penserbjorne: Thanks for the build! 2.6 works fine on my Alcatel One Touch Fire, but it is very slow.

I tried to do a swap partition on the sd card as suggested on the download page, but had no luck, /proc/meminfo always tells me “SwapTotal: 0 kB”. Can someone please show me how the partition should look like? E.g. the output of “fdisk -l /dev/sd?” on Linux with /dev/sd? being the sd card would be very helpful.


(Paul Sebastian Aguilar Enriquez) #23

Hey @tigny !! I thought I had already answered , nope, dont try to flash your phone, is for other model u.u sorry

@helmar Yes, the rom is a little bit slow, I been trying compile again but I just cant download the sources :frowning: and about the swap, I already sent an email to the guy who compiled it, the recomendacion is that the SD Card been at least class 8 or 10, you need a faster I/O time, some kernel tools as “free” doesnt work, so I dont know if the kernel tools doesn’t detect the swap, or if the swap doesnt working, sorry :(confused:


(Cyril SAINTIGNY) #24

OK @penserbjorne, dont worry I didn’t try anything! I’ll be waiting though. I did update a ZTE Open C to FF OS 2.5 and I think it’s quite nice.


(Paul Sebastian Aguilar Enriquez) #25

@helmar the problem with the swap is fixed, if you have an already sd card then you only should execute an script to enabled the swap in the device :slight_smile: the files are uploading.

http://mexmod.com/tutorial-swap-hamachi.html

Edit: Sorry, I need go to school, I will upload the files at night! You can download the files from v1.4, flash the boot.img and run the swap*.sh/bat file if you dont want wait until night!
Regards

Edit2: Ready :v the internet in school is faster than of my house! :v


(Helmar Gerloni) #26

Thanks @penserbjorne!

The swap script works fine for your 1.4 build, and I have swap now!

It does not work for your 2.2 and 2.6 images, I get “swapon: /dev/block/mmcblk0p1: Function not implemented”. The boot.img included in your 2.2 and 2.6 does not support swap, but the fix is quite simple: Just replace the boot.img file with the one from 1.4.

PS: The link on http://mexmod.com/download_otf.html to “swap-hamachi” gives a 404 error. The correct location is http://mexmod.com/files/otf/swap.zip


(Paul Sebastian Aguilar Enriquez) #27

Thanks! The link is fixed.

About 2.2 and 2.6 , I’m using right now the 2.6 with swap, did you tried just one time? or several times? If my memory is good I remember got an error the first time, and in the second try all was normal.

In fact, the correct image was from 1.4 so I replaced all the boot.img in all versions an reuploaded all in the morning :confused:


(Paul Sebastian Aguilar Enriquez) #28

Build from 16/02/2016 :slight_smile:

http://mexmod.com/download_otf.html#v2.6

Regards!


(Alex Sytnik) #29

Hello, Paul.
I want to build a custom rom (for Ukrainian locale) for my hamachi device.
So I have some questions that I like to ask.
Should I use sources from https://github.com/penserbjorne/B2G, will it be enough?
Do you have some tool-chain for the build task?
Do you use non-stock kernel in your builds? If so, which version?

Thanks.

P.S. And thanks for all your work.