SOLVED RuntimeError: CreateModel failed with error code 12293

Hello,
Not sure if this is allowed or not but I wanted to share this solution in case someone else is having the same error.

while trying to run deepspeech I kept on having this error message:
RuntimeError: CreateModel failed with error code 12293

solution:
I changed the tensorflow ver to match EXACTLY the one in the requirement file (currently tensorflow == 1.13.1). I tried ver 14.0 & it didn’t work.

The normal pip install tensorflow == 1.13.1 didn’t work for me so I had to install the whl file from here
& run (in the directory where the file is):
pip install tensorflow-1.13.1-cp34-cp34m-manylinux1_x86_64.whl

Hope this helps someone,

Thanks, that’s weird but that’s more of an upstream issue. Although I’m curious if you can share more details of “didn’t work”.

Yes, that’s expected, that’s why we document and depend on ==1.13.1.

I got cannot find matching version error message

Can you reproduce with --verbose and/or share more details on your system / setup ? It’s strange, it might happen to others, i’d like to know more :slight_smile:

Sorry I don’t know how to reproduce --verbose
I ran pip install tensorflow==1.13.1 --verbose but it says requirement already satisfied.
As for my env, I am running:

  • Ubuntu 16 VM on Win10
  • Anaconda py3.5

That’s maybe why you got into troubles the first time. Several people reported issues when using anaconda

Really? that’s interesting to know!
so is it better to switch to miniconda or just use python alone?

We only test with standalone python