[Support] Copy PlainText

(John Roblin) #21

Well it isn’t working for me any more. It did for a few days and then I updated and now nothing, not from the context menu or the keyboard shortcut. Could something else be interfering? Cheers.

(erosman) #22

Which Firefox version are you using?
Which page are you using it on?
I am on FF57.0a1 and it is working.

Try disabling it and re-enabling it and see what happens?
Try removing it and reinstalling it and see what happens?
Can you check if there are any errors in the console log?

It is possible that another addon interferes with it but that shouldn’t be so. :thinking:


Stopped working. Even “refreshed” my profile (i.e. deleted/restarted firefox profile). It no longer copies. if i use it, then paste, only my previous clipboard exists.
Debian 9/Firefox 56.0.1 Thank you.

(erosman) #24

Are you using the keyboard shortcut (which one) or ContextMenu?
Is it on any particular site? or everywhere?
Do you get any errors on the console?

WebExtensions shouldn’t need a refresh profile. Enable/Disable or Uninstall/Install (since it doesn’t have any preference) should be fine.


context menu ; everywhere ; no errors ; re-installs did not repair. i refreshed for multiple reasons, this being only one. Many addons seem to misbehave lately. And long-living of profile needed cleaning. Thank you.

(erosman) #26

There are a lot of conflicts, until they all get settled.

Can you start with all addon disabled and then only enable Copy PlainText and see what happens?
I was using it on FF56. I am on FF57 now.


failed with only “copy plaintext” and “restartFox”(needed something to retain my session) enabled. Is there a logging feature? i see an empty “browser-extension-data/copyplaintext@eros.man”.

(erosman) #28

No… No debugging data to the console. I was looking for an error from the browser itself.

Out of curiosity, can you install an older version like 1.2 since 1.4 has a different copy code for FF56+ and it may be the reason (on Debian).

BTW, which version are you using?


1.4; that’s it, 1.2 worked!!!

(erosman) #30

hm … that means FF56 on Windows and Linux are not the same.

Please use v1.2 and I will make an update to use the older copy code for linux.
Does anyone have any confirmation on Apple?!!


Much appreciated. Locked to 1.3 (since it also worked). Will unlock in a week or so.

(erosman) #32

Now that is strange since v1.3 uses the same new copy code as v1.4
The only difference is that in v1.4 I made 2 copy function, one like v1.3 for 56+ and one for FF53-55 (same as v1.2 copy) :thinking:


OOPS, after restart 1.3 failed. so sorry. FF 56.0.1 (64-bit) … confirmed 1.2 and restart works.

(erosman) #34

Update: I found out that OOP is not enabled on Firefox on Linux and MacOS and that is the reason.


v1.5 is out
New Copy code only works on FF56+ on Windows (due to OOP), so disabled it on Linux/macOS


thank you! working as expected.

(Dmitriy Goldner) #36

Unfortunately, the version 1.5 does not work for me in Firefox 56.0.1 64-bit on Windows 10 Pro 64-bit Fall Creators Update. I tried earlier versions of the add-on, and none of them work. Here is the list of add-ons I currently have installed in Firefox. Maybe you can determine which one of them might be causing the problem. Thanks for your help.

(erosman) #37

You have a lot of addons and mostly legacy. I didnt notice anything but you can try with all addon disabled and enable them on one by one to see.

Do you get any errors in the console.log?

(Dmitriy Goldner) #38

No error messages at all. Disabled all add-ons manually (except Copy PlainText), restarted Firefox, with the same result.

(erosman) #39

v1.3 & v1.5 use different copy function for FF56+
If v1.3 doesn’t work either, there is a problem somewhere.
I am on Window 7 64-bit and no problem with any of the version. Could it be Windows 10? I doubt it but has anyone else had any problem with it?

(Dmitriy Goldner) #40

Update. Got this message in Web console: 01:22:43.154 moz-extension://b55721eb-d8a8-456e-a412-927d435ae107/background.html: chrome tabs query did not return a result while changing window focus.

I do not know if this applies to your extension but this is only extension related error message I have seen.