[Support] Flash Control


Your add-on is the best in blocking Flash and HTML5 elements. But only two things I’m missing so very much:

  1. This pesky A sign that stands for HTML5 audio embeddings cannot be deactivated. I understand the function of this and it is great that the addon is supporting this. But why is
    there no possibility to disable it similar to the Adobe Flash and HTML5 Video block option? And/or why is this A sign isn’t placed to a constant position where it isn’t in the way like now?

  2. I haven’t tested it until right now: Does your plugin syncs the whitelist settings via Firefox Sync with other computers? That would be smashing! :slight_smile:

Please tell me: Is it possible to add the two features? The first one is the most important because it would be logically and similar to the existing options. I’m so looking forward to it!

(blueskyy) #83

Ans to 1: Yes, it is possible.
Ans to 2: You tell me.

(Rhodes6619) #84

I get this error

On YouTube, TMZ, etc.

The audio plays, but no video.

I believe it is a result of a conflict with Element Hider Helper

If I disable Element Hider Helper or set Flash Control to “allow” and clear cache, the video plays normally.

Firefox 42 rc2

(blueskyy) #85

While your report is good and descriptive, I don’t see anything wrong with what you were reporting.

Let me give you an analogy… Let’s say you took your baby brother’s toy car away from him, right in front of him. Instead of asking you for the toy car, your baby brother went to his sister to ask for the toy car. While his action might seemed logical to some, it doesn’t seem logical to me.

In our case, if you want to let Element Hider Helper manage and elements, simply go inside Flash Control configuration panel (accessible via the sidebar) and uncheck “Block Adobe Flash” (for embed elements), and/or “Block HTML5 Video” (for video, audio elements) I will be adding in yet another checkbox for “Block HTML5 Audio” in the future, but that’s another story.

Alternatively, you could just set Element Hider Helper to “not hide” embed, video, and audio elements, if that is available.

Something’s got to give, right?


Absolutely great news! :relaxed: I hope this is coming soon! :wink:

(jase) #87

Flash Control doesn’t block sites from using Flash to find out my real IP address?

Tested on http://whoer.net/extended and real IP is revealed via Flash even with proxy.

(Rhodes6619) #88

I must admit, I don’t understand the analogy. I thought you’d simply be interested to know that for whatever reason, these 2 popular addons don’t behave well together at this time, and since this is the official Flash Control support page, I assumed this was the appropriate place to report it.

This was not an issue up until the last 3-4 weeks fro me.

I appreciate and employ Flash Control for it’s unique and specific features. As far as I am aware, in that regard, Element hider helper has nothing in common with Flash Control…it has no influence whatsoever on video or audio related elements, and there are no settings to that effect.

According to the product description at [Element Hiding Helper for Adblock Plus 1.3.4][1],
[1]: https://addons.mozilla.org/en-US/firefox/addon/elemhidehelper/

“Fight the text ads! Element Hiding Helper is a companion extension for Adblock Plus meant to make creating element hiding rules easier”.

You did say “Something’s got to give, right?” I hope it doesn’t mean having to choosing between the two.

(blueskyy) #89

Short answer is: No, it doesn’t stop Flash from finding out your real IP address.

Longer answer is: Sites usually employ easily techniques to find your IP address, doesn’t have to rely on flash.

(Vuvezeg) #90

[BUG] Override Ajax Anchor setting causing Comments display problem.
I am new to this discourse.mozilla website so i appologize if I am posting in the wrong section.
If Override Ajax Anchor is checked, then clicking on “View All Replies” in the comments section causes the page to scroll back to top. To reproduce this bug, check Override Ajax Anchor, then go to the youtube comments section of any video and click on the “view all replies button” under a popular comment with many replies. It might say “view all 5 replies” or view all “72 replies” depending on the number of replies to the comment. Upon clicking, the page will scroll to the top and more replies would have loaded in the background.

Also can there be an option to keep Ajax Anchor Disabled even if Youtube is white-listed. Disabling Ajax Anchor is handy as it allows a few other addons work as well.

Quick edit: Another bug (or feature) is that blocked html5 videos only stop “auto play” but they continue to buffer and use up bandwidth in the background.

Do the following and test on whoer and you should see N/A.

Step 1. Find the location of the file mms.cfg on your system.
The mms.cfg may be located here:

On 64-bit: C:\WINDOWS\sysWOW64\Macromed\Flash\mms.cfg
On 32-bit: C:\WINDOWS\system32\Macromed\Flash\mms.cfg
Please note that you need
administrative permission to open the files with Windows. Open the
mms.cfg file using Notepad or Wordpad (or any text editor) in
administrator mode.
(To set the text editor as admin mode simply right-click on the icon and select “Run/Open as administrator”.)
Mac OS:
/Library/Application Support/Macromedia/mms.cfg

Step 2. Add the following line to mms.cfg:

Step 3. Test it on http://whoer.net/extended. If the result for “Flash” is “N/A” your Flash Player cannot leak your IP anymore.

(blueskyy) #92

You posted in the right place. I’ll look into that this weekend. Thank you!

If you did not have youtube “blocked”, no, there should not be an option to keep “Ajax Anchor Disabled”. It doesn’t make any sense (at all).

And the last bit is NOT a bug, I’ve already addressed it on numerous occasions… And since I’m not a broken record, nor intend to be one, I’m not going to repeat myself…

(jase) #93

@vuvezeg, thanks for that useful tip. It works perfectly, now the flash IP detection is N/A.


I tell you! :slight_smile: No, the settings of your add-on are NOT synced with the internal browser function. :pensive:

(blueskyy) #95

That ISN’T a bug. That IS supposed to work that way. If the url is “http://something.com/some/page#xyz”, it is supposed to go to whereever #xyz is tagged/anchored on the page. If there is no “xyz” behind the “#”, it will just go to the top of the page. If you don’t believe me, you can double check with the HTML specs.

(blueskyy) #96

The update is already in the queue, awaiting a full review.


Hello, some websites (like the one we’re on at the moment or bandcamp.com, for example) have URls this way:
From what i understood, each URL with different [partofwebsite] should be added to whitelist separately. Would be nice to have(or to have easier to find :wink: ) an option to add “[whatever]bandcamp.com” or any other site to the whitelist.
Keep up the good work!

(Nick Mun21) #98

I have found that after firefox updated to latest version on a Mac running osx, the flash control icon normally in the tool bar, disappeared. I tried customizing but it is not there and not anywhere. Is there a way to bring it back. I want to say I had the same issue on a windows machine and there was a way to restore it into firefox, but I cant for the life of me remember how… Thanks !

(blueskyy) #99

New version, v2.0.9 now uses SQLite. If the problem was related to a corrupted database file, updating to v2.0.9 may fix the problem. Just a guess.


Firefox 43.0.4, Flash Control 2.0.9.
Site “Let me google that for you” doesn’t work, page is static, example, screenshot.
Search on site rutracker.org doesn’t work. After pressing search button i see 3 requests in log but page with results is not shown (screenshot).
Adding sites to whitelist solves the problem.
P.S. I could not find addon’s page using firefox search (builtin or web page). Google works.


Firefox 43.0.4, Flash Control 2.0.7
A couple of weird bugs showed up after the recent update.

  1. On YouTube VEVO videos, if YouTube is whitelisted (“allow youtube.com” selected), the video player gets stuck in a loop, continually restarting after about half a second in. If you have it in normal blocking function and just hit play, it goes fine. This doesn’t happen in normal videos so presumably it’s related somehow to the VEVO connection.

  2. Tumblr archive pages come up with image thumbnails displayed as blank and in a single column, instead of in rows. Clicking on the blank square still brings you to the entry. I was surprised to find that it was Flash Control causing this problem since there doesn’t seem to be either Flash or HTML5 on there - there’s no FC button, and whitelisting the site doesn’t fix the problem, only disabling it does.

(blueskyy) #102

Are you sure it’s version 2.0.7? I’ve 5 reports telling me that v2.0.9 was faulty, and since then, I’ve taken down both version v2.0.8 and v2.0.9 because both were the recent “redesign”. Have you tried v2.1.0 yet? It’s also based on the v2.0.9 design skeleton.