Swisscows search extension overrides home page(s)

I tried the Swisscows search extension, but when it’s enabled, it sets itself as the home page and there doesn’t seem to be any way to stop that except by disabling the extension. So I’ve disabled it until such time as they change this behaviour.

1 Like

If you would like to add Swisscows to your search engines, you can use this method instead"

  • Open https://swisscows.ch/
  • Click the “Page Actions” menu button in the address bar (•••)
  • At the bottom, click Add Search Engine

Unlike like search engines added through extensions, this one would be removed using the “One-Click” search engine list on the Options/Preferences page, Search panel.