Tablet display hardware has an intermittent loose connection


(lmorchard) #1

So, I just unboxed my tablet. After letting it charge for a few hours, I tried powering it up.

What I got was a screen that was solid white on one half and full of glitchy lines on the other. That seemed to do some odd things like an arcade machine self-test. Then, nothing. I had to hold down the power button to get it to shut off. Another attempt at power-up did the same thing.

Here’s a video of the issue taken with my phone

Is my tablet dead-on-arrival?


(lmorchard) #2

Hmm, actually, it seems like there’s a loose connection inside: I tried turning it on again and picked it up by one corner. That seemed to torque the thing ever so slightly, and the display resolved into the “Made with Mozilla Technology” logo.

I set it down, and the screen went out again. Can pretty much always get a working screen by giving the thing a very slight twist or putting pressure just so on the lower left corner. But, the fix isn’t permanent. Touch works, but if I jostle it the wrong way, the screen goes out again.


(Steve Lee) #3

It appears that the display connections are borked. We’ll figure out how to best resolve this for you.

PS thanks for confirming the power button will shutdown.


(lmorchard) #4

For what it’s worth, I’m a Mozilla employee and will be in the Mountain View office for the week of June 16th. Does it make sense for me to pack up this tablet & bring it with me to return?


(Steve Lee) #5

@asa Can this be made to work for @lmorchard?


(Andrew [:feer56] ) #6

Ouch! Seems like something that could hit the trash right now :wink:


(lmorchard) #7

So, I’m on a plane to Mountain View this coming weekend. Should I be planning to pack this thing in my suitcase? Is there someone somewhere who wants it back?


(Steve Lee) #8

As Asa is off enjoying himself I suggest you contact Sammy.