Temporary Flatfish builds


#21

If that’s the case we really need community builds to continue with our work. I would also like to see working locales.


(Yousef Alam) #22

I actually fixed and enabled all locales for both Nexus 4 and flatfish last week, but the builds are failing now. We need someone smart like @atilag to fix it.


(Juan Gómez) #23

Since my Flatfish died three months ago, I didn’t try any build :frowning:
I’ll take a look and try to fix it ASAP


(alex_mayorga) #24

Cause of “death”?


(Andrew [:feer56] ) #25

Hey folks,

It is indefinite we’ve lost partner support. Asa has just recently returned, and we’re working with him to get some more details out to you guys as soon as we can. Stay tuned…


(Anirudh S) #26

@yousef Can you tell us the error message during build failure?

I have been trying to build for flatfish on Ubuntu 14.04 over the last few days but have been failing too. The error was along the lines of arm-linux-androideabi-g++ refusing to compile some ‘universal js cpp’ file. Sorry, but I don’t have access to it right now and will post the exact error message later.

Note: I even cross-checked that I had enough system space (30GB) to ensure the reason for failure wasn’t as mentioned here: https://developer.mozilla.org/en-US/Firefox_OS/Firefox_OS_build_prerequisites#Requirements_for_GNU.2FLinux


(Yousef Alam) #27

Here’s the last bit of my log, not sure what’s wrong here.


(Juan Gómez) #28

I’ve filled a new bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1164610
Already have a fix.
I hope to land it by tomorrow/friday.

@alex_mayorga I don’t know the cause, one day I tried to switch it on and the screen just flashed repeatdly but never shows anything…


(Andrew [:feer56] ) #29

Thanks for all your work @atilag!! :slight_smile: :slight_smile: :slight_smile:


(Anirudh S) #30

@yousef That is exactly the same error I was facing.

@atilag Thank you! By the way, I had the same screen-flashing issue for a while but I continued charging it. The tablet came back alive when I checked it later.


(Pavithran) #31

Hey guys I havent been following much … I heard of Firefox os 3.0 . Does it run well on flatfish ? Is there a build which I can directly use. I am on some 2.x build.


#32

I’m using @yousef build https://yalam.co.uk/b2g/flatfish/20150427.zip

This build is ok.


(Gabriela) #33

That’s good to know! I’ll try it as soon as I can! Thanks!


(Yousef Alam) #34

There’s a new build in the link in the OP. The last commit in that build is from the 8th May (some more build breaks to deal with), but I’ve enabled all languages and keyboards, so hopefully it will now be useful for l10n.