Thread: Add-ons not working due to certificate expiration

I am having the same trouble as everyone else. I open up my Firefox browser and all of sudden my add-ons are gone. When I attempt to re-download my add-ons it says I have no internet connection? Except that I am streaming and able to post here?
Its frustrating because I have been making the gradual switch from the Google giant and Firefox was a great alternative. Firefox and Mozilla let me down today.

4 Likes

Very strange, it rebooted for me in the middle of what I was typing. No warning or nothing. Lost all my addons except 1 (WebRTC Leak Shield).

1 Like

I’m having the same problem. what gives!?

1 Like

I also have experienced this issue across my work and personal machines with different versions. As of now, only my 64 bit firefox has its extensions. All of the 32 bit installs are extension-less now.

It’s as if “someone” snapped their fingers and wiped out all of the extensions.

4 Likes

I have a 64bit Firefox and the only extension that’s left with mine is Rikaichan (=an online mouse-over for Japanese script).

Not to mention the themes I accumulated over the years! Just… Blown to smithereens…

(I don’t think someone’s got a time-machine stashed somewhere so we could go back and stop that ‘someone’ from snapping their fingers? ;-))

2 Likes

Hello folks. Can only speculate as to the cause of the problem but have a workaround for you until this is fixed. Not perfect but better than nothing.

  1. Go to the addons page for the extension you need back again.
  2. Right click “Add to Firefox” then “Save Link As”, and save the .xpi file somewhere you can find it.
  3. Open up a new tab and go to “about:debugging”, and “Enable add-on debugging”.
  4. Click “Load Temporary Add-on” and find the extension’s .xpi that you just downloaded.

Your addon will be enabled but will only work until you close firefox again. Repeat steps 1, 2 & 4 as required for other extensions you need.

Once this is fixed properly, please remember to disable addon debugging from step 3.

8 Likes

Another quick work-around is to manually change your computer’s date to yesterday. This will allow you to re-download your add-ons.

2 Likes

I have this issue as well.
It says “Download failed. Please check your connection.” but that is a lie. Downloading the addon file manually via another computer on a different internet connection, then trying to install the addon on this computer, produces the real error that the addon is corrupt.

This happens with every addon, regardless of what it is, or the internet connection I use.

It is a server-side problem.

I am switching browser to Chrome until this is fixed.

1 Like

none of my adons are working your update fubred the firefox enjoyment please fix it my firefox updated today to latest version but as soon as I opened it and everything my addons were declared out of date by firefox. I re-installing and everything, but the site sometimes says, “download failed. check your connection” even when I have a very good internet conection full bars and everything and the extension downloads, it says, “addon could not be installed, it seems to be corrupted.” I tried reinstalling firefox and I still get the corrupt message. what did you do

1 Like

I’m a long time ff user, too, and I’m hoping this is a temporary problem. Even the extensions that are listed on their approved list aren’t working.

1 Like

Hi, guys
Please manually set your time to 5/2/2019 or before. then download add-ons again. this will temp solve the problem. mozilla is crazy. how could they remote disable my add-on? DO NOT CHANGE your time back, otherwise mozilla will disable your add-ons again.

Looks like they’ve rolled back whatever change they made. I’ve set my time and date back to current, and everything’s working the way it was before.

Edit: It seems that while re-downloaded add-ons might continue to work after changing the date back (mine do, at least), the date needs to be rolled back to download any more.

For me the error is still there…hopefully they fix it fast.

I am having the same issue–ALL my addons are showing up corrupt on ALL our computers–come on man my kids do homework on their computers do you really think I want their stuff exposed because of Mozilla remotely disabled our addons–REALLY mozilla get it fixed!

2 Likes

I somehow miraculously managed to get my AdBlockPlus back. (Seriously, I don’t know if I could replicate that feat!)
Still missing all my themes. AND had to improvise concerning my Avira AntiVir. :frowning:

EDIT:
Nope, false alarm. It just got deactivated again! T_T
BTW. setting the date back to before The Snap (= 2019/05/02) does help. But! Then Mozilla might advise you to change back or else something(s) might not be able to work.

EDIT #2 (2019/05/05, 01:24 CET):
May the Fourth be with you! Well, maybe the Force was with me? :wink:
Or…‘Somebody’ snapped their fingers and everything was alright again?
Either way, as suddenly as the themes and add-ons disappeared, they’re back again!? :sweat_smile:
I do not know whether the enabling of the studies-things that’s been talked about was responsible for this spooky miracle or not but… I am happy nevertheless! :relaxed:

Thanky VERY MUCH to all the incredible people over at Mozilla who undoubtedly worked tirelessly to solve this crisis! :kissing_heart::kissing_closed_eyes::heart_eyes:
(And yes, I do know I might be a tad bit dramatic but come on! This IS a big issue! I’m keeping my fingers crossed that that’ll be a one-time thing, though. FYI, I did bookmark several other browsers just in case! :yum:)

1 Like

so approximately how many add-ons were affected? (apparently all the ones i use) did this also result in a “Download failed. Please check your connection.” error when trying to add new extensions?

1 Like

Same here. I refuse to use Firefox without an adblocker, so I’m off to Chrome.

6 Likes

Suddenly, just a few hours ago, I can not use my signed obfuscated extension. What’s wrong ? Isn’t it stated that this will go into effect on June 10, 2019 ?

3 Likes

Are all Add-On apps on hold now? I just get “Download Failed. Please check connection” while clearly online.

2 Likes

thank you!, I literally step out for an hour and they disappeared, then found its way into the depreciated apps folder.
if its any help, overbiteWX was the only app that didn’t move into the legacy extensions folder…