Thread: Add-ons not working due to certificate expiration

A certificate expired. It’s a huge goof. Conspiracy theories are not needed.

5 Likes

The gall, when they even post “Firefox is not made for profit, its made for its users.”
Well if you care that much you have till the end of the weekend before I scrap Firefox period.

Can’t believe I actually recommended this to people.

3 Likes

Temporary fix via /r/Firefox: https://www.reddit.com/r/firefox/comments/bkfg4f/is_there_no_way_to_force_the_disabled_plugins_to/emgaxhf?utm_source=share&utm_medium=web2x (worked for me in Ubuntu 18.04).

1 Like

On my system, the issue appears to have disabled the extensions for Edge browser as well, suggesting it may not be an issue limited to FireFox.

Just went to a site that is famous for ads… and didn’t see one… and yet I get the same “Add-on disabled” messages for the two I use.

May have been lucky though…

Hey folks! This was due to a certificate issue and the team is currently working on a fix.

You can track progress on this thread: Certificate issue causing add-ons to be disabled or fail to install

6 Likes

so any idea how long we have to wait

Not yet, but I’ll update the other thread when we have an ETA.

1 Like

why don’t you try Linux?

Seems like everything has been affected.

1 Like

At least i’m happy to know i’m not alone in this one. That thing scared the crap out of me. Couldn’t find information in any blog post or social media. Hanging tight with you guys for a solution.

4 Likes

it happened to me during the middle of a session
i legit got a chill down my spine when the notif showed up
i am actually frantic over this

I’m really fixing to stop using FF period. Add-ons not working, adblock not working, theme disabled. I tried to also go back to FF 65, but the dang thing kept auto-updating and I didn’t want it to do that. Frustrating. I’ve been using FF since I started with the computer back in 1995…Come on people, get your act together.

2 Likes

Horrible thing this issue with Firefox. In this moment is practicaly useless this browser without the add-ons like the popup blockers or publicity blockers.

It havent sense reinstall old versions like FF57. The issue is the same

people of support please fix this urgent problem ¡¡¡¡¡¡

1 Like

Made the same thing, it worked for a while, but now my add ons and theme disappeared again

i’d recommend waterfox
it’s what i might jump to if this tomfoolery continues

2 Likes

This is the first time in 5 years that I’ve seen an ad, I know none of my passwords, and reddit looks like crap. I need my addons!

1 Like

Here are some updates from the Mozilla Add-ons Twitter: https://twitter.com/mozamo/status/1124513193030586368

2 Likes

ohmigod, I’m so glad to find these posts! I thought I was going insane. Sent a request to support and the suggested fix didn’t work. I was working away on FF 66.0.3 and suddenly my Acrobat and Norton(!!) add-ons just disappear! I tried to fix and keep getting the message that these add-ons are corrupted!! as others have said, I’m ripping my hair out!

3 Likes

GUYS PLEASE TRY THIS:

  1. install ESR, developer, or nightly edition
  2. open about:config
  3. change xpinstall.signatures.required to "false"
    you can now re enable all extensions

The user soft bed posted this on Twitter, and now my extensions are working.

Original post: https://twitter.com/hot4headpats/status/1124519061516378112

Please give it a try!

Good luck!

2 Likes