Unable to login to mozillians


(Rubinbhandari) #1

Hi there
I have been unable to login to mozillians.org,other logins are working fine.Bugzilla,reps.mozilla and other persona site logins with the same mail are working fine


(erosman) #2

I had the same problem. I restarted Firefox with addons disabled and then I could login fine.
I suspect it had something to do with NoScript or Ghostery but I have not checked.
Try and see …

I also filled a bug at the start:
https://bugzilla.mozilla.org/show_bug.cgi?id=1195778


(Rubinbhandari) #3

I am only having problems with mozillians login. Rest are working fine


(erosman) #4

As I said… my problem was only with mozillians.org login too.
Please read my previous post.


(Rubinbhandari) #5

I did try that but the problem persists.I have filed a bug and got response for like a day then no response at all


(Alberto Castro) #6

I am having the same problem and it happens on Firefox or other browsers as well.


(Tasos Katsoulas) #7

Hi,

Could you please provide more information about your problem? Are you getting any error messages? Which one of the available methods did you use?


(Alberto Castro) #8

Hi Tasos,
I try to login but I only get shown the email field, not the password field. However, after I insert my email address I get an error message (image below).
Plus, there is no option to recover my password (I tried this method too). I could try to sign up using Git-Hub but then I would end up with two Mozillian accounts and that is not on my interest.

Capture


(Tasos Katsoulas) #9

Hi Alberto,

If the email in your GitHub account is the same with the one linked with your Mozillian profile then you should be able to login to your existing account. Could you please try that and let me know?


(Alberto Castro) #10

Hi Tasos,

The thing is I’m not sure which one of my email accounts I’ve used to sign up to Mozillians.org. I don’t sign in to my Mozillians account for a long time now. That’s why it would be much easier if I just could recover my password inserting my Mozillians username, that way I would get a password recovery email in one of my email accounts.

Plus, I’ve tried to sign in with my GitHub account and it prompts me to create a new Mozillians account (this is sort of helpful in a way that I know that That email address is not the one). At least if I could just email Mozilla about this, but there is no contact list at Mozillians.org.

Thanks Tasos


(Tasos Katsoulas) #11

Mozillians.org does not have a password field. Prior to the current changes (GitHub login) it was only passwordless and LDAP. LDAP passwords are not managed by mozillians.org. Before that it was Persona which did not support passwords either. This is the reason why there is not a recovery option.
For all the login options, apart from LDAP, login was working by verifying your email. With the new changes mozillians.org is asking you to login with the most secure option. In this case Github is considered more secure because it has MFA enabled compared to the passwordless option.

I can help you sorting this out. My guess is that there is a mismatch between the email you are using in GitHub and the email you used to register your profile in mozillians.org. We can use the bug you opened in Bugzilla [0] to solve the login issue you are having.

[0] https://bugzilla.mozilla.org/show_bug.cgi?id=1418006


(Alberto Castro) #12

Thank you Tasos,
I’ve replied to your message at Bugzilla. :wink: