Unity Webplayer Not Supported

Iam trying to get a web-game working,that needs Unity,but I noticed that Firefox doesn’t support it anymore. Is there a way I could downgrade Firefox so that I can use Unity again? The add-on that is supposed to replace Unity doesn’t do it’s job right, so that’s why I’am writing this e-mail.

Use Firefox ESR v52. ESR will support Unity until June 2018.

If you happen to need something older than 52, you can get other versions here.

All versions older than v52 are insecure since they don’t get patches. v52 should be the oldest version that is still safe. v52 ESR, not v52 stable.

This post was flagged by the community and is temporarily hidden.