Use Markdown as text file format


(Stefano Cecere) #1

i think it would be a killer feature for Firefox, and a good choice for Mozilla, to store all Notes directly in .md / Markdown format, following the http://commonmark.org

GitHub is pushing Markdown to the masses (not only developers)
more and more text editors are going Markdown (see Ulysses, for example)
and anybody worried about data preservation agrees that the Markdown text format is the best compromise of readability and portability

if the Notes plugins would save in .md, we could open them in many other text editors

i know that currently Notes is based on CKeditor… but there are many Markdown JS/html editors around! see for example https://simplemde.com/

what do you think?


(Kevin "Ilphrin" Pellet) #2

I can’t do anything but approve this :3 It would then be really easy to import/export notes from other editors (Like Turtle) or fro writing articles on Jekyll or Ghost


(Stefano Cecere) #3

ahh i see in today’s Notes 1.9.0 update that the Font Size selector has been substituted with a p/H1/H2/H3 with a “Basic Markdown features” changelog :wink:

and maybe we could try a CKEditor plugin like https://ckeditor.com/cke4/addon/markdown to switch from styled to markdown views…


(Mirek) #4

Is it possible to disable markdown (or switch editor to plain text mode)? Can’t use texts with underscores and asterisks anymore :frowning:


(Mark12547) #5

One could still use * and _ but one would have to “quote” it with a preceding \ character.

The above line appears like this to me while editing it (I had to add a lot of \'s to get it to take the * and _ as display instead of start/stop of italics. :slight_smile:

One could still use \* and \_ but one would have to “quote” it with a preceding \\ character.

For code, one could use three back-ticks (shift-~) and the highlighting language (such as C, javacode or use text for no highlighting) to start and end a multi-line block and the characters wouldn’t be interpreted, e.g., the next line is ```text then the first sentence of my reply then a terminating ``` to end the block of text:

One could still use \* and \_ but one would have to "quote" it with a preceding \\ character.

If you see the above line as super-wide, it illustrates a problem with block code: one has to supply the line breaks (Enter key) where needed because block code does not automatically word wrap.


(Mirek) #6

Thanks for reply. Using backslashes to escape some characters is very inconvenient.
Back-ticks - I did some simple tests - and they don’t work well. Actually they spoiled whole text area - I’m not able to write anything, deleting single characters and selected text is not possible any longer - neither with Backspace nor Delete key. CTRL+X and Cut, Delete/Remove commands from context menu have no effect.

I tired to reproduce in Fx58 (different profile) steps that caused problem - but after few back ticks were added, some of them removed, then pasting inside and outside back-ticked block some PHP variable name with underscores - and this time all markdown syntax (and normal formatting) stopped working (but I can still write). Something I originally wanted - but probably not through some sort of a bug… Deleting whole text (CTRL+A, DELETE) didn’t fix markdown/formatting in text area. Had to restart Firefox, but then, after adding few back ticks it stopped working - as in first case (Fx57 profile). Closed one window (of 2) in Fx58 - and then, in other window, Notes became editable again. Very strange behavior. Tried same thing in Fx57 (closing some windows) - and noticed that editing Notes works fine in all other windows. Only one, where this bug(s) occurred is still not editable.

Summing up - it only reassured me that I want to disable markdown syntax.


(Stefano Cecere) #7

i don’t understand your problem:
with the current 1.9.0 version you can write anything… *, _ and ** are used to format corsive and strong only in the body of the text and you can write anything if not paired.
it only converts an * to a bullet point if it’s at the beginning at a line 8and i think it’s good)

(note: i’m under FF 58 beta… but i think it’s not changing anything…)


(Mirek) #8

Try for example to write down names of functions - such as: mysql_real_escape_string() or vars like $_POST[$var_1] in your note or to write formula like: x*2(y+z)*w - and you will see where is my problem. It makes code unusable. Using CTRL+Z just after text formatting is applied to undo it helps a bit, but still is inconvenient.
And bullet points… - also not very handy, if you create comments to code snippets (JS/C/C++/C#/PHP/…) like this:
/** comment
* comment continued
* same as above…
*/
However, not so annoying as mentioned earlier removal of underscore and asterisk signs from text.


(Stefano Cecere) #9

ahh… got it. i agree the automatic markdown formatting isn’t for everyone… and maybe safer to disable it or have a toggle button plain source text / formatted


(Natim) #10

I tried and I agree with you that it is really inconvenient. I used ctrl+z to remove the autoformating. However if you paste it is works. Do you manually type code in your notes?


(Mirek) #11

Hi!

Yes, I typed code manually (of course I often pasted too - but this usually worked fine).
However I already stopped using Notes for some time and the day before yesterday finally disabled them (but still didn’t uninstall :-)).
I will still keep an eye on further development and changes with new releases of Notes - but for now I’m using Notepad++ for all my notes.


(Natim) #12

Issue filed here: https://github.com/mozilla/notes/issues/595