We have a bug already


(Steve Lee) #1

Thanks to @rbrandao we have a bug cannot access the sdcards

Keep them coming everyone.


(Gabriela) #2

The battery icon doesn’t indicate that it’s charging, could this be a bug?


(Raniere) #3

The battery icon doesn’t indicate that it’s charging, could this be a bug?

Are you sure? For me it’s fine.


(Gabriela) #4

I am sure! It happens with the wall charger and with the USB charger.


(Caspy7) #5

Hmm. Perhaps it would be best if people included what version of the OS they were on for now?
If we standardize on one version, this of course won’t be as much of an issue.
I happen to know that gaby2300 is on 2.0 and I’m pretty sure that raniere is on 1.4. (In reference to the disparity of observation for the battery icon.)


(Gabriela) #6

Yes, I’m with 2.0 and I have the issue every time I charge the tab. The battery icon indicates it’s charging during the first two or three seconds, then the “charging” does not show any more so it’s difficult to know whether it is actually charging or not.


(Raniere) #7

@gaby2300 Could you open the Settings -> Battery when charging? Maybe this solved the problem for me after updating to 2.0.


(Gabriela) #8

I tried but I get the same result as before. Settings>Battery doesn’t even say "Charging"
I forgot to say I get the issue when I charge the tab turned on. When it’s turned off the battery icon works fine.


(Steve Lee) #9

I’d say there’s enough evidence that something is going on and we should create a bug. Even if turns out to be as simple as charging level tresheshold it’s worth raising as a bug and moving this discussion there it. If we ge a clear answer then we can update the wiki pages. Can some one create the bug?

Re FxOS version - yes we’ll need to specify if not the shipped 1.4, otherswise much confusion will result.


(Gabriela) #10

I will create the bug as soon as I can!


(Gabriela) #11

I’ve been testing some apps in my 2.0 tablet during the weekend. Some don’t work. I’d like to know if I should file bugs or just use the developer’s email within the apps to report the issue. All these apps work fine in my Keon (1.3)


(Steve Lee) #12

If these are apps bundled with the OS then raise bugs.

If you installed them from the market place then I’d suggest raise a bug and contact the author referencing the bug asking them to update it. That way we’ll track platform bugs and problems app developers have because of the new format and hardware. To some extent it depends on the exact nature of the ‘not working’

What do others think?

Did you you see the meta bug for ux problems? https://bugzilla.mozilla.org/show_bug.cgi?id=1018519


(Gabriela) #13

I installed the apps from the marketplace do I’ll start filing bugs about them and contacting the authors asking them to update it.
The ‘not working’ means tapping the icon the app didn’t load, or the game worked so slowly it couldn’t be played at all, or the game not recognizing the tablet was already in the landscape mode.

Besides the above, some apps came with advertisements, is this allowed? I mean, in one of them the app covered part of the game’s display so the game couldn’t be played at all, in another game I finished searching all hidden objects, an advertisement showed up so it was impossible to go on playing.


(Gabriela) #14

I filed 2 bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=1019288 and https://bugzilla.mozilla.org/show_bug.cgi?id=1019297

I contacted the authors referencing the bug and asking them to update it.

Some of the faulty apps give a website as contact, would it be worth it to create the bugs and contact the sites?


(Raniere) #15

I filed 2 bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=1019288 and https://bugzilla.mozilla.org/show_bug.cgi?id=1019297

@gaby2300 Could you include at the bug report the informations at “Settings” ->
“Device information” -> “More information”? AFAIK you don’t need to include “MAC
address”, “IMEI”, “ICCID” but the others fields should help when testing the
bug.


(Gabriela) #16

@raniere, of course!

I’ve added the following information to both bugs:
OS version 2.0.0.0
Firmware revision: flatfish_20140513-1003
Hardware revision: flatfish
Platform version: 32a.0a1
Build identifier: 20140513102237
Update channel: default

Git commit info:2014-05-09 18:18:19
7fe1f921

I hope the above is what you asked for! Should you need more information, please ping me!


(Steve Lee) #17

@gaby2300 Ads are certainly OK. This is a fully open ecosystem and many people need to make money. eg https://hacks.mozilla.org/2013/10/monetization-with-inneractive-on-firefox-os/. The issues you see are almost certainly layout issues due to the larger screen size .

Personally, not recognizing landscape drives me nuts on any platform as I often use my phone in landscape. For me it’s a part of responsive design. Defo a bug.

The other issues are more likely due to a new platform or large screen… Also bugs.


(Steve Lee) #18

@gaby2300 thanks for creating these bugs. This is just what we need to get the tablet support just right.


(Gabriela) #19

@slee, no problem at all! It’s just why I signed up for the TCP program!!! I mean, I signed up to test it, find out all that doesn’t work and file the bugs accordingly. And learning lots of new things as well!. :slight_smile:


(P T) #20

Hi. Has the official bug hunting program started yet? I mean, if all tablets have been shipped, should we then start focusing on bugs? @slee let us know for the phase of the project. Thanks