Zh-hk should display Traditional Chinese

l10n

#1

When the first language is set to zh-hk, Firefox Screenshots displays Simplified Chinese. It should display Traditional Chinese, just like zh-tw.


(Axel) #2

@zbraniecki, do you know how browser.i18n does language negotiation?

In Services.locale, zh-HK now goes through likelySubtags to zh-TW, right?

And each of those questions with “starting with Firefox XXX?”


(Zibi Braniecki) #3

It should work correctly:

Services.locale.negotiateLanguages(["zh-HK"], ["zh-CN", "zh-TW"]);
Array [ "zh-TW", "zh-CN" ]

What are the steps to reproduce the issue? Maybe we have some place in our code where we don’t use the LangNeg API?


#4

The steps to reproduce the issue:
1)Set zh-hk as the first language in Firefox language list (in about:preferences#general)
2)Visit Firefox Screenshots. The page is in Simplified Chinese.


(Zibi Braniecki) #5

What you are selecting n about:preferences are locales Firefox broadcasts to web pages. That’s not the same as locales used for its own UI (including extensions).

To change that, you’ll need an zh-HK Firefox - https://www.mozilla.org/en-US/firefox/all/?q=Chinese%20(Traditional),%20正體中文%20(繁體)


#6

No. When zh-tw is selected, Firefox Screenshots is in Traditional Chinese.
Firefox Screenshots (https://screenshots.firefox.com/) is a web page, so it is affected by this setting.

And I am already using Traditional Chinese Firefox.


(Zibi Braniecki) #7

Gotcha. Screenshots is both - a website and an extension. I thought you’re talking about extension.

This should work well then. We have zh-TW localization and we use correct lanuage negotiation. Can you file an issue at https://github.com/mozilla-services/screenshots ?