ZTE Open C

(dattaz) #1

Hi all,
This is a topic to speak about what we have done in community build for ZTE Open C in french mozilla communaty. The result is http://builds.firefoxos.mozfr.org/

What we have done
We setup community build for zte open c, with fota support : went you install a build, you will receive update over the air, no need to reflash.
Flashing is done with adb sideload or flash zip in recovery.

Building part :
We have document all your build setup on mdn : Building and installing FOTA community builds
The builds are building on someone server, and then upload on mozfr server
We use buildbot, which automates the compile cycle (each night for nightly, and 1-click button for other build).
We can have overview of build, and see specific build, with log of output

All build (except nightly build) are tests by hand and by people, we use a simple form like this

Other people made bug report. Some made also patch (this is really amazing, thanks all !)

All our configuration for buildbot, patch or shell script are on github : github - mozfr/buildscommunautaires

We have setup this configuration in february 2015 (before we use shell script with cron, irc notification, but without log). Since this time, we have try more than 600 build.

If you have question, ask. If you need help to made the same for your phone, also ask :wink:
We are also on irc : irc.mozilla.org chan : #buildopencfr

(dattaz) #2

What we want to do

  • Setup a transition branch :

Building transition for open c work, but building zip to flash ( ./build.sh gecko-update-fota) doesn’t work,
we have too much argument or tools/update-tools/build-flash-fota.py fail to create edify script.

Traceback (most recent call last):
File “tools/update-tools/build-flash-fota.py”, line 130, in
File “tools/update-tools/build-flash-fota.py”, line 124, in main
File “tools/update-tools/build-flash-fota.py”, line 56, in build_flash_fota
output_zip, update_bin)
File “/home/ad/transition/B2G/tools/update-tools/update_tools.py”, line 1219, in build_flash_fota
File “/home/ad/transition/B2G/tools/update-tools/update_tools.py”, line 1327, in build_flash_script
File “/home/ad/transition/B2G/tools/update-tools/update_tools.py”, line 1388, in build_permissions
File “/home/ad/transition/B2G/build/tools/releasetools/ota_from_target_files”, line 261, in SetPermissions
script.SetPermissions("/"+self.name, self.uid, self.gid, self.mode)
File “/home/ad/transition/B2G/build/tools/releasetools/edify_generator.py”, line 219, in SetPermissions
self.script.append(‘set_perm(%d, %d, 0%o, “%s”);’ % (uid, gid, mode, fn))
TypeError: %d format: a number is required, not NoneType

  • Build for b2g-installer :

Some people asking for what :slightly_smiling: cool, but need time and motivation. We have started for zte open c EU/UK because we have cynogenmod port for it, but a
lot of issue…

(Lapineige) #3

Thanks @dattaz for this awesome report and work ! :slightly_smiling:

Unfortunately I don’t have my Open C with me for a long time, so I can’t help you there.
But I invite every Open C owner to raise their hand and try to help you making builds or testing them :wink:

Your buildbot setup is really cool and will be handy for the users and contributors.

About your building issue, maybe you can post them here to get some help and advices :wink:

(dattaz) #4

yep, sorry i have forget log

(Lapineige) #5

Well I have no idea of the functioning of this script, but at least you could try to add this
print (uid, gid, mode, fn)
Just a line before the one that is blocking (strangely, it’s the 303 for me and not the 219), just to understand which variable is not existing instead of having a numeric value.

(Kevin "Ilphrin" Pellet) #6

Hey @dattaz!

I have some time in the nexts weeks to give some help on this with my Open C ( as I don’t use it anymore as my current smartphone, I can break it with some build without hesitation :wink: ). I was thinking more precisely about building the transition branch, I’m cloning B2G to try this.

(Nhirata) #7

I haven’t tried with the Open C.

Can you try building a separate repo for the flame and seeing if that works?

Because building for the flame and the Open C should be similar, the only difference should be the backup directory.

(Nhirata) #8

I just remembered something.
Did you add “export B2G_UPDATER=1” in your .userconfig file?
If not, try running B2G_UPDATER=1 ./build.sh gecko-update-fota

And I think what you really want is :
B2G_UPDATER=1 ./build.sh gecko-update-fota-fullimg

You may want to read : https://developer.mozilla.org/en-US/docs/Mozilla/B2G_OS/Building_and_installing_B2G_OS/B2G_OS_update_packages closely.

(dattaz) #9

\o/ I have now a transition build for open c (and it’s booting)
I will setup url update and i will post it on website

(Lapineige) #10

As you said, \o/ !
That’s really cool, I gonna test it ASAP :slightly_smiling:

(Sai Karthik Karra) #11

Great ! please place the links for any new builds here as i linked this topic on mdn for Zte open c. :slight_smile:

(Lapineige) #12

Here’s the build link that dattaz sent to me: http://builds.firefoxos.mozfr.org/openc/transition/
It’s just gecko+gaia, bluetooth is not working (the patches are not applied yet), only in French for the moment, and flashing takes a lot of time (>20min) as it’s quite verbose.
The builds are done every nights :slightly_smiling:

If you have an Open C, please test it and send some reports here ! :wink:

Here some screenshots done on my phone, with the build of Monday 10th:

(Kevin "Ilphrin" Pellet) #13

It fails to install on my Open C :confused: Seems like it is for FR devices not EU (I bought mine on ebay)

(dattaz) #14

yep ZTE open c FR ONLY currently

(Kevin "Ilphrin" Pellet) #15

Can I help in some way to make it working on EU open C? :slight_smile:

(Hubert Canon) #16

I tried the transition update but it takes forever to install

(Cyril SAINTIGNY) #17


after reading your post I got my ZTE Open C out of its box ('been there for a month or so) and started it on. It downloaded more or less 113 Mio, made some kind of update (there was a orange screen for once) and now it is operative again but I think the “Logiciel Boot2Gecko” in the information is the same as before there was an update…

Anyway, thank you for the work you put into B2G.


(Lapineige) #18

That’s right, more than 20 minutes for me. It’s because it is very verbose.

(dattaz) #19

Normally you have Settings->Device information ->More information-u>update channel : transition

(Cyril SAINTIGNY) #20


you requested some tests:

I have the same version as shown above.

When using Facebook (sorry) there is a bug insofar as I can not move down the posts… Only what is shown on the for logon is visible… The screen just streches when I slide my fingers on the screens but it doesn’t move down.