ZTE Open C


#41

Hi there,
Been busy, so sorry I didn’t get back sooner. Before I start, do I have to use b2g-installer, or can this be flashed from SD card?

I’ll be upgrading from the last (February) nightly for the Ebay EU Open C.

Cheers.


(dattaz) #42

no problem, you must use b2g-installer


#43

Thought as much, thanks. I’ll try and set some time aside tonight.
Cheers.


#44

Hello fellow b2g-fans!

Have been trying to update my Open C (Ebay) phone for a couple of days now but always get stuck when b2g-installer is trying to flash the system.img, I have left it on over night but it never gets pass that part and then it is “bricked”. I manage to unbrick it by fastbooting a recovery image, sideload a “FFOS to Android” update and then I’m able to use the rooting procedure shown on “mozfr.org”.

I have tried using b2g-installer using the “zte_p821a10.blobfree-dist.zip” from “http://builds.firefoxos.mozfr.org/opencebay/transition-blobfree/” from “clean” rooting, rooting + nightly(update-20160226075113.zip) and rooting + nighlty-old-work-20151231113541.zip but with same result.

Am I doing something wrong? Cheers!


(Olivier) #45

Hello !
I encountered the same problem than @k96hkh ! To unbrick my phone I restore a backup made with ClockworkMod recovery.


(Lissyx) #46

We cannot diagnose anything if you don’t describe precisely what you did and how you did it. We also need logs to investigate.


#47

A successful flashing should not take more than 20 minutes on a USB 2.0 port (and it’s usually much faster than that).

I need more information. Can you provide the log from b2g-installer after the failed flashing attempt? You can find it in the web console (Menu > Developer > Web console, or Ctrl+Shift+K). For this thread readability’s sake, use https://pastebin.mozilla.org/ to paste the log and just give the link here.

Like @lissyx said, a step by step list of all the actions you performed in order to flash your phone would be useful to make sure you’re not missing anything important.

@oli, you should do the same so we can tell whether you’re facing the exact same problem or a different one.


#48

Thanks for pointing where to start. I started all over and here are the steps I did:

  • Phone doesn’t boot
  • fastbooted a recovery image (boot not possible to flash)
  • sideloaded an image I found a long time ago that takes FFOS to KIS …
  • Use OpenC update tool (windows) with "FFOS_EU_EBAY_P821A10V1.0.0B06_LOG_DL"
    Now it should be a clean rooted Open C Ebay phone

Start firefox-nightly (I’m using arch linux) and start b2g-installer

  • Phone is detected
  • Select “zte_p821a10.blobfree-dist.zip” and flash
  • Downloading, extracting, downloading blobs, creating builds all looks good
  • Flashing builds starts (flash system.img) and never ends
    log from web console can be found here https://pastebin.mozilla.org/8913297
    It was quite long so and removed most of the pull and copy arguments

Let me know if I should pull any other log or I missed anything. Cheers!


(Lissyx) #49

Can you please try using the VM ? I don’t see anything obvious in this, device is detected in fastboot mode.


#50

Also make sure you plugged the phone on a USB 2.0 port (USB 3 can cause the battery charger to behave erratically, especially with fast charge ports). Use a USB 2.0 hub if necessary.


#51

First time I tried it (some days ago) was with the VM on a windows computer but to be sure I tried it again today but with the VM on my linux machine, unfortunately with the exact same result. Here are the two last lines from the web console output:

Devices enumerated, MUST be fastboot Object { id: “aa10ae4” } about.js:1121:5
Using Object { sourceDir: “/tmp/b2g-installer/zte_p821a10/cont…”, imageFile: “/tmp/b2g-installer/zte_p821a10/imag…”, partition: “system” } from system.img about.js:1142:9

I have been avoiding my one “blue” USB port which should be the only USB 3.0 hub, the other show up as USB 2.0 hub with lsusb.

None of the usb ports has the plus sign so they shouldn’t be fast charge ports.

After the last flash fail I tested something that might be worth mentioning. The image files are saved under /tmp/ so I saved them, actually the whole b2g-folder. I though that 300 plus something Mb system.img sounded large so I tested with fastboot flash -S 4096 system system.img and it did go through (didn’t work before without the -S 4096) and it worked flashing the boot.img. Now the phone kind of boots and I have a nice rocket flying over the screen :slight_smile: … never stops though, the recovery is different too.

Hope it can be to some help, thanks for all your help!


#52

Hi folks!

I really want to test new updates of B2G for the open C and it is so frustrating that I can’t get it to work. After testing and trying so many things (different computers, OS, USB-ports, hubs, cables etc.) I don’t think it is a USB problem. It seems to me that my fastboot (the one that comes with the the ZTE rooting image) is having problem with flashing, does it sound reasonable? When I’m flashing images it most often fails but randomly goes through and only with the -S option.

If so, is there any other fastboot that can be used for transferring images?

Since I have the images created by B2G-installer can I transfer them to my phone in any other way then with fastboot?

Cheers!


#53

Hmm, I thought that was just my phone acting up, but since you seem to encounter the same issue as I do, there is probably more to it.

What I do when it happens:

  • Unplug the USB cable, turn the phone off and remove the battery
  • Wait 10-15 minutes
  • Put the battery back in its slot
  • Hold the volume down button and power buttons to enter fastboot
  • Plug the USB cable
  • Run ./flash.sh

Usually it works fine, but as soon as the phone has booted the OS once, you need to remove the battery and wait 10 minutes again to get a working fastboot.


#54

Thanks for the tips Bonstra. I tried and it did not seem to make any difference for me when trying to flash the whole image at once. In any way I guess it can be a good thing to do before attempting to flash anything anyhow :slight_smile:

When I use the sparse function (fastboot -S) I can get it to push through around 77 chunks of about 4 Mb (so it seems to be the whole image) and ends up saying flash was successful. I flash the boot image and restart the phone. I get to the point where the rocket is flying over the screen but not further (I have adb functionality at this point). Any idea what could be wrong?

Cheers!


(dattaz) #55

Maybe your profile, if your haven’t wipe data
anyway if you have adb, you can run adb logcat to see what is wrong.


#56

You were right dattaz! Once I wiped the data and cache it booted up and I’m finally in :smiley:

Very nice and clean look! Is there anything in particular I should test and give feed back on? If so, should I write it here or is there any other place I should record things I think needs improvement?

Thanks a bunch and you are all awesome!


(Prosvirnin Arseniy) #57

Hello!

I bought ZTE OPEN C a day ago in Russia.
B2G installer recognize it as ZTE Kis 3 so i can’t install EU blobfree dist.
How can I turn my device in EU or I need to make own package for my phone?

Thanks.


(Lissyx) #58

They probably have a specific variant, might not be compatible, hard to
tell like this :-/

Could you share result of |adb she’ll getprop|?

<
https://ci6.googleusercontent.com/proxy/YyUkFJtJG0Fnjg3RwNkXiQghp1LeZbAku55bxOrxBZ-2aAwINryNkS5U1qZm9c2CQYeQnkXkGy2AcETix9xEvxVhcjakXoA4SP6eT-5dT6FGkcd2n4LmQNYcmcMvOM2lVXKQuRpg2zZXWvUs7TIZB3ww-IhG0PDl5LFkym7AMchT5x-hurBTZhIK=s0-d-e1-ft#https://discourse.mozilla-community.org/user_avatar/discourse.mozilla-community.org/prosvirnin.arseniy/45/5999_1.png>
prosvirnin.arseniy Prosvirnin Arseniy
October 25

Hello!

I bought ZTE OPEN C a day ago in Russia.
B2G installer recognize it as ZTE Kis 3 so i can’t install EU blobfree
dist.


(Prosvirnin Arseniy) #59

Shure! Here it is:

http://pastebin.com/SCa67q1x


(dattaz) #60

ZTE kis 3 is ZTE open c. It’s recognize as Kis 3, but you can choose a .zip to flash no ?