"Error issuing the certificate. Try again." while trying to set up Webthings Gateway


I am very new to the Webthings Gateway technology and was very excited to get involved. I ordered the neccesary parts to set everything up and followed the “getting started” guide. But now I am stuck and I don’t quiet know how to solve this problem.

I am stuck at creating my own mozilla.iot domain with the error: “Error issuing the certificate. Try again.” I could go on without creating a domain and do everything locally, but I specifically want to be able to take control from outside the household.

See picture (I got the dutch version):

Webthings error

Does anyone know what could be the problem?

Hi @Nawin_N, welcome!

It looks like you’re using a pre-1.0 version of the gateway which is no longer supported. (See here and here for more information).

You need to download WebThings Gateway 1.0 from the website here, which uses the new replacement tunnelling service at webthings.io.

Hope this helps.


1 Like

Thanks for your quick reply Ben!

I might have gotten the file from Mozilla, which I just read, departed ways from Webthings such a shame…

I will try again using the version from webthings.io and report back!

I can comfirm that Ben’s solution works for this problem.
Mozilla really should update/remove their page and refer to Webthings.io which does work!
Again, thanks @bfrancis I can get started now!

Glad this worked.

To be fair, there is a message at the top of the page which says:

Note: The WebThings community has now moved to webthings.io (read more).

Perhaps that isn’t clear enough.

I actually did see that! But it said that the community had moved to webthings.io and not that the software is not supported anymore. With them having a functional download link available and an elaborate getting started guide, I thought that the software would still be functional but for support you should go to webthings.io

I am getting the same issue with a new Gateway setup.
It is definitely pointing at webthings.io so is, presumably, the current build.
I have tried multiple times with no joy!