How to test deepspeech on my computer?


(Rain1) #1

Hello

I understand that this is alpha software, and will not be as accurate today as it is later and that you don’t want to give people a bad impression of deepspeech from an unfinished version.

That said I would really like to get it working and try it out! I am not sure exactly what to do as this particular line from the readme is failing:

$ deepspeech output_model.pb my_audio_file.wav alphabet.txt lm.binary trie
Not found: output_model.pb; No such file or directory
terminate called after throwing an instance of 'util::ErrnoException'
  what():  native_client/kenlm/util/file.cc:76 in int util::OpenReadOrThrow(const char*) threw ErrnoException because `-1 == (ret = open(name, 00))'.
No such file or directory while opening lm.binary
Aborted (core dumped)

perhaps there are some extra data files I need to download?

Thanks for any advice you have!


(Lissyx) #2

Hello,

All those files are going to be released as a one bundle soon :). You can already have lm.binary and trie file if you have a git clone of the repo.


(Rain1) #3

okay. I suppose I need to wait for the rest of those files then! Thank you.


(Lissyx) #4

It’s live, you can download it from the release page: https://github.com/mozilla/DeepSpeech/releases


(Justin Gosses) #5

Adding a comment to promote clarity as I read this post before and didn’t realize it would have solved a problem I was having.

When I got this in output
Not found: output_model.pb; No such file or directory
It was solved by going to

  • https://github.com/mozilla/DeepSpeech/releases
    and downloading the language model (which wasn’t downloaded for me when I did "git clone or “pip install deepspeech” at
  • https://github.com/mozilla/DeepSpeech/releases/download/v0.1.0/deepspeech-0.1.0-models.tar.gz
  • and expanding it inside your deepspeech folder
  • and then (assuming you’ve install python bindings vis pip install deepspeech) running the command deepspeech output_model.pb my_audio_file.wav alphabet.txt lm.binary trie
  • or alternatively change the name of the .pb file in the command above from output_model.pb to output_graph.bp… if that is what it unpacked to… and run the command above
  • I had to run that command from inside the new models folder created when you expanded the result of step 2

(Nnpths01) #7

I followed this and got

Traceback (most recent call last):
File “/home/naveen/tmp/deepspeech-env/bin/deepspeech”, line 7, in
from deepspeech.client import main
File “/home/naveen/tmp/deepspeech-env/local/lib/python2.7/site-packages/deepspeech/client.py”, line 10, in
from deepspeech.model import Model
File “/home/naveen/tmp/deepspeech-env/local/lib/python2.7/site-packages/deepspeech/model.py”, line 21, in
_model = swig_import_helper()
File “/home/naveen/tmp/deepspeech-env/local/lib/python2.7/site-packages/deepspeech/model.py”, line 20, in swig_import_helper
return importlib.import_module(’_model’)
File “/usr/lib/python2.7/importlib/init.py”, line 37, in import_module
import(name)
ImportError: No module named _model


(Lissyx) #8

Please refer to others topic with the same error. This output by itself is not useful, and there are plenty of examples of extra debug informations that you should provide to help us diagnose, like LD_DEBUG=libs env variable when running.