Installing Vidyo on Ubuntu


As a contributor to Mozilla, it could be very easy to find yourself in a little silo, just working away on your computer with little or no face to face interaction with staff or fellow contributors. I am lucky that in SUMO that we have a very active community on IRC, but further to burning out a little last year, I thought I would augment that with getting the more personal contact in a video meeting.

The MoCo choice of video conferencing software is Vidyo, but once you have downloaded the client, Mozillians who use Ubuntu may find that the software will not install. This is because it needs a dependency to be met first of all - a file that needs to be in place that it cannot find.

Despite being a Linux user, I am not a big fan of the terminal. I know it exists and it serves a purpose, but I do not believe I should have to use it all the time - I like a nice user interface to click on. That said, when I do use the terminal, I like to keep things very simple.

I was therefore very interested by a solution from rail, published by armenzg, that appeared to be fairly simple to walk through:

Install equivs package by typing (in terminal):

 sudo apt-get install equivs

Generate a control file by typing (in terminal):

 equivs-control libqt4-gui

Find the file and open it in text editor. Edit these lines so that they read:

 Package: libqt4-gui
 Version: 4.8.1
 Description: fake package to please vidyo

Once saved, go back into terminal and type:

 equivs-build libqt4-gui

Followed by:

 sudo dpkg -i libqt4-gui_4.8.1_all.deb 

Now you should be able to double click on the Vidyo installer and it will work.

This is the method that worked for me on Ubuntu 16.10 and a Mozilla Nightly build of Firefox. I am grateful to rail and armenzg for making it available as well as alex_mayorga and the SUMO team in Brazil for helping make sure it works. I sincerely hope that other Mozillians can make use of this if you have a similar issue.


Hi @Seburo,

Issues with Vidyo keep here, on Debian based distros like Ubuntu and Deepin Linux, and now on Fedora 26 too.

This is the message that I received in Ubuntu, Deepin and Fedora:

$ VidyoDesktop
/opt/vidyo/VidyoDesktop/VidyoDesktop: error while loading shared libraries: cannot open shared object file: No such file or directory

It’s a really gatekeeper for my contributions with the community programs at Mozilla.

Worked for me. Thank you for sharing that little trick… :smiley:


Did you go through the steps to create the fake package of libqt4-gui_4.8.1_all.deb?

1 Like

Yes, but I can try this again.

Hi @Seburo,

I solved this problem installing the libqtwebkit4 too, I wrote a script here.

thank you

1 Like

We need a bit of internationalization of the README file :sweat_smile:


Having found that Vidyo works fine on Ubuntu 17.04, I have just updated to 17.10 and found that it will not run.

Still looking into this, but any help appreciated.

@Seburo - did you have any luck getting it to work in 17.10?

@Seburo @jturner On Ubuntu 17.10 you also have to install some Qt tray support for it to work properly:
sudo apt install sni-qt

@jturner @Tilman_Kamp

Many many apologies for the delay in coming back to you on this topic, I have been a bit swamped.

There have been a few different methods recommended, some work for some and have varying degrees of complexity. I found recently that Gparted is not a fan of wayland and prefers xorg and I am sure that these types of issues mean it is challenging to find a one-size-fits-all-distros approach.

I have heard a rumour that Mozilla is not far off rolling out a replacement that will be cross-platform. Whilst I really want to have Vidyo working again, I am quite happy to wait and see what is coming down the tracks for everyone versus trying different solutions.

1 Like

Thanks this thread helped me today :slight_smile:

1 Like

I think it will be very helpful if vidyo can be distributed as a snap package. It will reduce so much complexities for users.

1 Like

If you have issue on ubuntu 18.04 this guide helped me: