[Support] uBlock Origin

(Vas Vadum) #482

I’ve been trying to diagnose whats been causing this odd issue for the last several days now. After fiddling with a whole bunch of different things for a while, finally getting some help, eventually I found out uBlock Origin is the cause.

uBlock Origin is blocking all images on the internet that are loaded when I click them via discord. If I click a direct image URL via the discord desktop app, or discord web app, the web page in firefox loads nothing, just white nothingness. Tests shown that the image was delivered to my PC and that I received the image, but the browser was just showing me nothing. This happens to any website at all. For the sake of giving examples, this is the current image failing to load;

The others which now load because I loaded them after disabling the entire addon,
Actually they no longer load either, all this diagnostic stuff and reinstalling ublock from scratch seems to have broken it even worse now.

I’ve disabled all filters, I’ve “turned off” ublock, and still doesn’t work, but if I disable the addon entirely, images begin loading properly. This seems to have started happening after the firefox update to 55.0.3 - 64bit but I can’t be entirely sure. No new addons have been added, nothing else has been changed. I am unable to do any more to diagnose this issue. I know its uBlock, I just don’t know why.

It seems to actually be an interaction between Grease Monkey, two of the scripts my greasemonkey had enabled: KeepVid Helper and Anti-Adblock Killer | Reek.

I’ve disabled the scripts for now and things seem to be workng normally again… I’ve no idea why this sudden interaction happened but I’ll go ahead and leave my post here.

(Laozi83) #483

supprimé et recréé en anglais, excuses

(gwarser) #484

Please try disabling userscripts like “Anti-Adblock Killer | Reek” https://github.com/gorhill/uBlock/issues/2930

(5cb 1ksb7e7rrvbd) #485

ive already answered that question. copy paste:
firefox has better adblocking capabilities than google chrome bcos google makes tons of money with ads :slight_smile: nothing the extension developers can do about that switch browsers or accept ads.


uBlock just updated itself to v1.14.0, which is incompatible with and gets forcefully disabled by Firefox 52.3.0 esr. I used the link to v1.13.8 from the description for transferring settings to restore function, but I have a few questions:

  • Is this accidental or deliberate? Is support for 52.3.0 getting dropped as of this update?
  • If not, where do I need to check for when a compatibility update gets released?
  • In any case, what’s the situation with the version I’m now using (https://addons.mozilla.org/firefox/downloads/file/685614/ublock_origin-1.13.8-an+fx+sm+tb.xpi)? Is it going to auto-update at any point? If not, and future versions of uBlock won’t support my browser, how practical is it to keep using this version? Will it get disabled/broken by something in the future?


Using Firefox 55.0.3 and have uBlock 1.14.0 and when the extension is enabled and I press F5 on a tab with https://twitter.com/ loaded, it stalls out and page never loads. If I press the Refresh button on the navigation bar, it stalls out and never loads. If I click the X which gives a blank white page and then Refresh, the page loads. Pressing CTRL-F5 works fine. Note, just turning it off for Twitter.com does not work, I have to completely disable the extension. How can I better troubleshoot this?

(Raymond Hill) #488

You have other extensions installed? If so, first thing is to try uBO alone, with all other extensions disabled (restart Firefox to be sure).


Note, I’m also talking about it here: http://forums.mozillazine.org/viewtopic.php?f=48&t=2965271&p=14764486#p14764486

So far, if I enable any of the following extensions with uBlock, it stalls out on Twitter:

  • Add Bookmark Here ² 55.0.20170705
  • Extension List Dumper 2 1.0.2
  • Add to Search Bar 2.9
  • Html Validator
  • CoLT 2.6.7
  • Context Search 0.6.4
  • Custom Buttons
  • Element Properties 9.1-signed
  • Extension List Dumper 2 1.0.2
  • JSONView 1.2.4
  • Places’ Tooltips 3.0.20110409.1-signed.1-signed
  • Screengrab (fix version) 0.99.11
  • Thumbnail Zoom Plus 4.2
  • User Agent Switcher

With these extensions, it is still working fine:

  • Classic Theme Restorer 1.7.0beta2
  • Classic Toolbar Buttons 1.5.8beta3
  • CookieKeeper
  • Download Status Bar
  • Easy Youtube Video Downloader Express 9.17
  • Emoji Cheatsheet for GitHub, Basecamp etc. 2.0.1
  • Extension Options Menu 2.18
  • FireGestures 1.11.1
  • Print Edit 18.3
  • RoboForm Toolbar
  • Status-4-Evar 2017.03.19.12b
  • Stylish 2.0.7
  • Tab Mix Plus
  • uBlock Origin 1.14.0

I’m sure I have more extensions that it will and will not work with. Note, with all these extensions in my 52 ESR install with uBlock 1.13.8, Twitter is fine.


Hi Raymond,

In the past few weeks I’ve found that usatoday.com no longer is displayed on my phone. The page comes up completely blank. If I disable ublock, or whitelist ustoday.com, it displays correctly with ads.

It used to display correctly with the ads blocked with the default settings.

I’m running Firefox 54.0.2 on Android 6.0.1.

Thank you

(Laozi83) #491

since version 1.13.10, in the “Filter lists” tab, grouping (click on the - in front of network filter (s…) to hide unchecked filters no longer works.
the first occultation works but after consulting another tab and returning to the “Filter Lists” tab, all lists appear.
FireFox 55.0.3 32-bit FireFox uBlock Origin 1.14.4

(Daniel Rosik) #492

Firefox crashes with uBlock and “alert window logins”


Since a couple of days I have noticed a very annoying bug. Every time I visit a page with a “alert window login” Firefox crashes (don’t know the real name of this specific login window but please see the screenshot, https://drive.google.com/open?id=0B-Yj5ivtOVuCZlVBREN0R2EwMlE) .

This applies to all types of unrelated web pages, even the admin page for my router. This behavior seems only to appear to these specific login pages. Other types of logins work OK.

I have tried disabling all my add-ons and enabling them one by one, this is only related to uBlock. I have also reinstalled uBlock with only the default settings. I have tried this on two different computers, at home and at work. All tries with the same result. I can visit my router admin page on sections that are not password protected like the status page but as soon as I click on a section that requires login Firefox crashes before I even see the login window.

I using Firefox 55.0.3 (64-bit) and uBlock Origin 1.14.4 on Windows 10 (both computers).

Can anyone please help or confirm this?


(5cb 1ksb7e7rrvbd) #493

most probably a filter list issue.
first update to the most recent version of firefox and ublockO.
then confirm problem persists with up-to-date filter lists.
if yes: isolate the responsible filter list by disabling and then re-enabling them one-by-one.
then report in the forum of the respective filter list developer.


Thanks. It’s the EasyPrivacy filter list.

(Raymond Hill) #495

Somewhat related: https://bugzilla.mozilla.org/show_bug.cgi?id=1313401.

Did you un-check Firefox’s setting “Accept cookies from sites”?

(Raymond Hill) #496

Firefox crashes (don’t know the real name of this specific login window but please see the screenshot, https://drive.google.com/open?id=0B-Yj5ivtOVuCZlVBREN0R2EwMlE2)

I don’t see how this can be related to uBO. If your Firefox crashes, you should submit the crashes to Mozilla, that is definitely not normal. Also check for malware on your computer – in any case, I can’t help you here, I don’t see this related to uBO at all.

(Laozi83) #497

Raymond Hill:
Somewhat related: https://bugzilla.mozilla.org/show_bug.cgi?id=13134011.
Did you un-check Firefox’s setting “Accept cookies from sites”?

yes, I am currently using CookieShield adonn and have disabled the “accept cookies” box in the Firefox privacy tab.


Hello: Sorry if I am not putting my question in the correct spot. I am new to this Discourse site and find it very difficult to understand.

I have upgraded to Firefox 55.0.3 and uBlock Origin add-on is preventing my ability to download .acsm files from ebscohost (this is a site where you borrow ebooks from).

Troubleshooting so far:

  1. disabled uBlock Origin – can download .acsm file
  2. enabled uBlock Origin and reset to factory settings – canNOT download .acsm file
  3. enabled uBlock Origin and unclicked ALL filters and ALL settings – canNOT download .acsm file

I have the uBlocker log page open but it is not telling me anything that is helping me.

What would be the next troubleshooting step?


(Raymond Hill) #499

Read the release notes, the steps of what you need to do are described there.


Thankyou for the link to release notes. Unfortunately the release notes/the reply does address my question. “What are the next troubleshoot steps”?

I had already disabled the legacy addons and found uBlockOrigin is the cause.

The release notes communicate
1 it is a known issue that you will have “some sorta” issue. That is very widespread.
2 it appears no known solution

I had hoped for an actionable step rather than there is no solution (otherwise downgrade to earlier version of the addon or disable the addon)


(Raymond Hill) #501

I had hoped for an actionable step rather than there is no solution (otherwise downgrade to earlier version of the addon or disable the addon)

Unfortunately I believe you may be suffering this issue (as mentioned in the release notes): https://bugzilla.mozilla.org/show_bug.cgi?id=1396226.

You need to report your own issue to this bugzilla issue, so that the Firefox devs are made aware of how common it is.