Add search engine icon to search box

search

(running Windows 10x64) #1

A couple of years ago, the Firefox design team decided to remove the icon of the currently selected search engine and replaced it with a general magnifying glass icon.

I feel this is utterly irritating and confusing.

I’ve taken courses on how to touch type, so I don’t need to look at what I’m typing. That’s the benefit of touch typing.

Firefox doesn’t support professional typing by having the currently selected search provider’s icon not always visible. The search box’s behavior is not apparent without taking particular action.

Here’s a screencast showing two searches plus a simulated eye tracking cross hair, showing the irritation that’s occuring when performing searches by activating the search box using acceleration keys <CTRL>+<E>, having the search result executed by a search engine that wasn’t expected to run the search query:

.

Please, bring back the search providers’ icons in favour of the currently used, uninformative magnifying glass icon.


(jscher2000) #2

Certainly a site icon would be more informative and aesthetic, but I’m not sure why you need it. Is there a reason you want to see the icon before starting your search? I ask that because the moment you type a character into the search bar, a drop-down appears that has the current default search engine listed at the top, so you can confirm where your search will be submitted (and, if you use suggestions, where the suggestions are coming from).

You can change to a different default search engine by right-clicking its icon on the drop-down and choosing Set As Default Search Engine.


(running Windows 10x64) #3

Absolutely. As you can see from the animation, the suggested alternatives are too time consuming. I want to focus on the web page’s content, not on the Firefox GUI, when I’m working at my machine.

Different search engine providers usually have a distinct icon color. So from the corner of the eye you can distinguish which search engine provider is currently selected without leaving focus from the text you’re currently working at.

While I’m typing the search query I’m not leaving focus from the text I’m reading. I don’t even actively recognize myself typing. The keyboard combination fully went into my muscle memory: <CTRL>+(<T>, <E>), search term, <RETURN>. Typed in less than a third of a second. Wading though the list of search engines that drop down while I’m typing would multiply the time it takes to enter a search term by 10 to 20 times. Too much, I believe, for such common operation.

Plus: It doesn’t hurt to show the search engine provider permanently. On the contrary: There is no reason to hide it. It’s a status icon, just like the green padlock icon left to the address bar.


(jscher2000) #4

Wading though the list of search engines

No wading, it’s on the top line:

As a regular search bar user, you know that the search bar always sends searches to your default search engine unless you do something special. Do you change your default search engine frequently, or often end up on a site other than your default search site?

I don’t know why the specific search engine icon was dropped; that was done in Firefox 34, which is ancient history now. Anyway, you can file a bug (if you do, share a link back here).


(running Windows 10x64) #5

Yes, I change my search engine at least once per session. That’s because I need information from different domains (translations to English, MSDN queries etc.).

I find myself regularly triggering a search query twice: Once with the wrong search engine, and then - after being confused by the result - again with the right one. That’s because I’m not aware of the currently selected search engine as I’m not able to recognize and react on the search engine icon within less than a third of a second.

I disabled telemetry, otherwise Mozilla would definitely be able to see a tiny, yet irritating peak in their usage statistics.

A bug report already exists:

But at that time, Mozilla developers didn’t get the point and resolved the current, information hiding behaviour as “WontFix”.