Address bar becomes second search bar and blocks access to specific URLs as a consequence

I still suffer with this awful behavior, which was mentioned already more times but never solved.
The really big problem and security issue is that suggestion, how it is called by FF is not a suggestion but information, what FF do regardless, the user wants.
Use case example:
I want to go to URL, so I put the URL into address-bar, I get suggestions from search engine even if I checked out “search engines” for address-bar suggestion. But much worse, regardless I press ESC or whatever button and the suggestions disappear, the ENTER results in sending the URL to search-engine and delivering page with its results.
Why is this a security issue:
The URL could be a secrete one used in some types of shares or there could be a need to test URL with password. Doing it locally (http://localhost/…) is (in some conditions) acceptable but the FF behavior, when it is actually send to search engine, i.e. internet, is totally not.
Why it becomes a blocker to FF usage:
There are URLs, where it is not possible to visit them anymore. There are of the type http://my-pc-name.my-domain:my-port/… (in hosts) and pasting or writing them in address-bar ends with search results page with no way, how to get to the URL at all.
Conclusion:
FF claims creating separated search-bar and address-bar, but in reality creates two search-bars with no possibility to access a specific URL in some cases. In others work correctly and deliver the content of URL. (maybe improvement with AI :slight_smile:)
So looks like being another case of app-behavior: We don’t care, what user wants, because of we know better, what to deliver.

If you disable search engine suggestions on the Settings page, Search panel, you should not get search engine suggestions (magnifying glass icon) below the address bar. You may get search history suggestions (clock icon). https://support.mozilla.org/kb/search-suggestions-firefox

Regarding unwanted searches from the address bar, even if suggestions are disabled, here are a couple approaches you could consider:

(1) Use a / after your string to force name resolution

Firefox should show in the top line of the address bar autocomplete drop-down that it intends to “Visit” the string rather than sending the string to your default search engine.

This is necessary when the top level domain of your host name is not in the ICANN list (for example, photos.cutekittens). If you use the TLD often, you can create an entry in about:config (browser.fixup.domainsuffixwhitelist.cutekittens, type: boolean, value: true) to force DNS resolution and bypass search.

Is that working on your Firefox?

(2) Prevent searches from the address bar unless you begin or end your input with a ? character (or click/highlight a search engine button)

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste keyword.enabled and pause while the list is filtered

(C) Double-click the preference to switch the value from true to false

Regarding the separate search bar: whether you use this or not has no effect on how the address bar works. (Other than intercepting certain keyboard shortcuts.)