Any workaround unable to remove always open in container

There are a number of known issue with firefox containers, but the one that gives me the most pain is #2263.

when you add a website to always open in a container, you cannot remove it. I have tried many different methods, but none work.

does anyone have the skills to give me some firefox console commands to completely delete the file that stores this information?

The theory is that the local file gets over-written by the firefox sync data. Is there a way to delete the file from the firefox sync bucket?

Thanks in advance.

I have the same issue, even after factory reset of firefox and syncing with a brand new account, adding the containers extension back in results in it trying to open every container in the same container.

This was one of the reasons I enoyed using Firefox so much in the first place (containers are a fantastic way to make sure you don’t accidentally log into the wrong customers portal) now its completely unusable for me.

All I need to do is turn off the always open option (please)

NB as suggested above - none of the suggested (easy) fixes for this issue work - I have had to turn off containers altogether.

You mean that following the instructions on doesn’t work?

Correct. I have to do that multiple times per day. I’m testing the behavior with container sync disabled but ideally I would find a solution that keeps sync enabled.

@Pcguy7 If it’s related to Sync that’s bug #2110!

I tried to reproduce it without success. You can try the instructions on to completely clear the sync data for Multi-Account Containers. I don’t know if you need to turn off Sync on all devices before clearing or if it’s enough to do it on only one devices. So you might have to experiment a little with that.

Sorry I don’t have a better solution to propose :(.