Borderify Extension not working (no errors)

Hi,
I’m working on the Borderify Tutorial.
What I made:

No errors are thrown
Sadly I don’t know how to debug it.
Thanks for any idea and help : D

Some more information:

  • I use Firefox 72.0.2 and Ubuntu 18.04
  • Disabled all plugins
  • on another PC it worked (I forgot to note the number)

You’re loading the extension temporarily using about:debugging?

Try testing on a different site. The Add-ons site and various other Mozilla sites are off-limits to extensions for security and privacy reasons.

1 Like

Thanks and I’m using the about:debugging site to load the plugin.
I now tested it on: www.mozilla.org and discourse.mozilla.org.
Sadly there isn’t a red line either.
Edited:
I found an error in the Inspect/ Console tab:
Could not map contract ID ‘@mozilla.org/sharepicker;1’ to CID {1201d357-8417-4926-a694-e6408fbedcf8} because no implementation of the CID is registered.
Error: Can’t find profile directory.
I’ll look does errors up Tomorrow.

If you open the Dev Tools panel on the page you’re testing and click Debugger, the Sources column should show the extensions that have injected content scripts. Is Borderify or any other extension listed?

General note: if you are testing in a private window, you need to go to the Add-ons page and enable the temporarily loaded extension for private windows.

2 Likes

Thank you for your time : D
I was in using a private window. Now it works.

1 Like