Building Gateway or Adapter on CentOS

Hi Team,

I was exploring building the gateway/adapter on the CentOS. The build fails while trying to build sqlite. It fails with the toolchain arm-linux-gnueabihf-gcc not found. I tried installing the toolchain externally but none of them work.

Do you have an exact package name for the required toolchain or Do we support building on CentOS or not?

Abhijit Nathwani

The gateway’s README includes instructions for Fedora, which should be very close (if not identical) to what’s needed for CentOS.

For adapters, there is typically just a script that needs to be run to build.

I’m not sure why you’re hitting an error for an ARM toolchain. What are you running CentOS on?

Hi @mrstegeman,

When running the ./ script on CentOS to build the gateway image, it tries to download the node module gateway-addon-node which in turn downloads sqlite3. The pre-build binaries for sqlite3 are not found on the url it tries to fetch, so it fall backs to compile it from source. That’s where the ARM toolchain comes into play. and it fails on CentOS. I tried various other relevant toolchains, but it is failing at exactly this step everytime.

Please find the attached screenshot of the error.


The ARM CC specified here in the script:

That script is specifically part of our Raspberry Pi image creation process (for Raspbian).

If you’d like to build and run the gateway yourself, you’ll need to follow the instructions in the README.