Building WebThings using DOCKERFILE errors when GIT'ing gateway-addon-python 1.01 alpha

I just tried to build the latest WT Docker image using the Dockerfile in WebThingsIO and the build process core dumps when it tried to GIT gateway-addon-python 1.01 alpha.

If I edit “requirements.txt” and remove the reference to an “alpha” version and use the default version the docker build completes and creates a docker image that appears to run.

I’m not up on git version dependencies so I don’t know if the default gateway-addon-python version defaults to the latest version (1.0.1 alpha) specified in requirements.txt or the image will have problems down the line since it was built with an older version gateway-addon-python.

Thanks for reporting, this is issue #2979.

Thanks Ben,

Also, the procedures to build a docker image on GIT WebThingsIO/gateway references the GIT WebThingsIO/gateway-docker repository (see below).

This repository is marked READONLY and is years old. It is not obvious and I attempted to git, build and run an image built using gateway-docker a couple different times in the last couple months. It builds but does not run (for me).

It would be great to place a large bold disclaimer on gateway-docker page notifying users that they are outdated.

Also, the build instructions in the “gateway” repository should be updated to remove references to “gateway-docker” to just “gateway”:


Hi @EricEdberg,

You’re correct that the gateway-docker repo has been deprecated and you should now build a docker image from the gateway repo.

I haven’t yet manually built a docker image myself.

Have you followed the instructions in ?

Does everything work the same except for the name of the GitHub repo?

Would you mind sending a PR to update, then I can also update the README on Dockerhub.