Cache Cache Cache

No matter what settings I do (and i’ve done all I can find on searches), Firefox Developer Edition is still caching files on personal server! This is supposed to be the DEVELOPER EDITION! Old versions I didn’t have this problem, but now I do and refreshing the page to not see any changes (or worse, think my changes didn’t do what I hoped) over and over is frustrating. Is there a way just to turn off any and all caching whatsoever once and for all? I want it to never ever ever ever cache a single file and ALWAYS reload files… whether it THINKS the file has changed or not. Note: sometimes if i add a blank space between lines of code, it will load the new file… small changes like changing a 1 to a 2 can sometimes take forever to load the new version, even after clearing cache